adb shell randomly exits... why?



  • Hi,
    I've been using VOXL1 Flight Deck for a few months, and lately I'm noticing that my connection using adb shell just exits. It seems to be getting progressively worse. This morning I try to connect and it disconnects within seconds, and sometimes when I try to reconnect I get an error (on Ubuntu): error: no devices/emulators found. I've tried multiple power supplies, and have disconnected the modem and removed my V2 USB expansion add-on board. Current draw fluctuates between 140-180mA.
    Any thoughts?


  • Dev Team

    @Ed-Sutter when did you start noticing this problem?
    I'm guessing that you've already tried different micro usb cables with the same result? Or even a different computer. We've had issues with hubs and usb cables, those are the most likely culprits. I would also say to try reflashing the board, you will have to get the board in fastboot mode for it to work since adb isn't working fully. @Vinny @modaltb any other suggestions on your ends?


  • Dev Team

    Another thing to verify is that any MIPI cameras you have plugged in are oriented correctly. If a MIPI camera is plugged in backward the VOXL will fail to fully boot.


  • Dev Team

    "+1" for a bad USB cable (happens all the time to me), but I would make sure your system cabling is all in place, secured, and any potential shorts are avoided from probe tips, antennas, exposed sheathing on shielded cables, soldered on probe points with exposed metal, etc.

    Generally speaking, once a Voxl boots, there is nothing really that would make it shut-down barring some physical (electro-mechanical) error, so loosing ADB is more likely not from Voxl, but rather the link between Voxl and the Host PC being intermittent.



  • @Adrian-Hidalgo @tom @Vinny,
    Thanks for the responses!
    As of this morning I think this, along with what I thought was a totally unrelated problem, is understood. Regarding this thread's topic (adb dropping), I had tried all your suggestions (multiple power supplies, different USB ports, etc..). The only thing I noticed was that when I changed USB ports on my host, the frequency of adb dropping would go down for a while. No clue why.
    Anyway, we're also struggling with an LTE issue using a modem (EM7565) that is not compatible with your modem add-on module. For now we've been plugging the M2 style modem into a M2-to-USB adapter and plugging the USB into VOXL. This only worked after switching to the V2 USB expansion board configured to supply more power (see this thread). With that expansion board the modem came right up (or so I assumed). Then I started debugging issues that I thought were related to LTE connectivity and the fact that VOXL doesn't formally support the EM7565; however, it appears that there is still a power problem.

    After a few weeks of LTE debugging/analysis, yesterday I stepped back and used a powered USB hub to connect the modem to VOXL and now things are working (i.e. the link has been up for almost 24 hours).

    So today I will be probing the USB power line to hopefully find a voltage drop that can be attributed to a slim trace or flakey solder joint between the USB expander and the M2-to-USB adapter.

    Sorry for the verbosity. I wanted to share the detail in case you guys have any other thoughts/suggestions.
    Thanks


  • Dev Team

    @Ed-Sutter This verbosity helps Ed, thanks for that.
    For the ADB issue, I would look for dust/build-up in your PC ports. Try an alcohol (denatured) soaked swab and run it into the port a few times to make sure the contacts are clean and dust free. When you pull it out, make sure to do so with a "removal angle stroke" where you are trying to pull out contaminants, instead of a "straight plunge in/out stroke" which can just compress/stuff more contaminants in there.
    For the M.2 adapter info, here are some points:

    • From my experience, those OTS USB M.2 adapters are very cheaply made, and most of them actually have a regulator on them from USB VBUS and they "just guess" and set to most commonly 3.6V or 3.7V, however, some devices only want 3.3V, or even 3.8V, so we validate each one and make sure to pair them up only with supported modules that spec-wise align. So, check your EM7565 VBAT specs, and probe the USB/M.2 adapter VBUS rail to make sure they align.

    • Voxl USB VBUS from the side port J8 is limited to approx 900ma-1A per USB3 older specs. This is also likely not enough for a modem, especially if it is dropped down by an LDO on that M.2 adapter. If it exceeds the current, it may flag the Host and I'm not sure if it then triggers a host reset??

    • Those M.2 USB adapters only typically provide a small 500mA-1A LDO. They are not well designed for Modems, more so for storage and WiFi use cases. You might be dealing with burst/cell-edge TX power/wake-up transient edge cases with such a LDO. If you have the part number of the M.2 adapter, I'd be happy to look into it, maybe buy one ourselves so I can probe it, and see if I can find out the LDO part number on there....

    Now, what does surprise me is the expansion board not working. We provide a direct link to the 5V input power which is provided by our power module. So, please double check the jumper settings on that, or if you know you are only ever going to use it in high-power mode, try soldering across the pads and skip the jumper. The image we show online is actually set for the "High Current" path, hence the "HC" on the silkscreen... 32c7dabb-a3a5-49f0-9fe3-941d2fda07d3-image.png
    In my career, I have found some jumpers to be of very high resistance (~100-ohms or so and intermittent), and not suitable for all power use cases.

    If the Powered Hub is working the best, then I agree there is a clue there about the power system.

    I really wish I can offer on-site support, as this may be something simple we are just overlooking (again, your verbosity helps a lot in place of being there 😉 ).


  • Dev Team

    Did you reflash the system image? Could be corrupted flash



  • @Vinny Quick note... I'm not claiming that the USB adapter is doing anything wrong. Not enough data to conclude anything like that at this point. I'm much more suspicious of the adapter we're using at the moment.
    Its also quite possible that there is just a bad solder joint somewhere on the USB-M2 adapter.
    Thanks for the tips, I'll certainly post back when we get this figured out.



  • @Chad-Sweet I did that last week. Had no effect. I'm getting more convinced that this is a hardware/assembly issue with the M2-USB adapter.



  • @Vinny Just re-reading my last reply to you. The wording of the first sentence may be confusing, so rewritten...

    ... I'm not claiming that the "ModalAI USB-expansion add-on board" is doing anything wrong....


Log in to reply