VOXL2 ADB not working



  • Hi, we have a problem with using Sentinel through ADB.

    We bought Sentinel and we were able to connect with ADB. Also, other packages such as voxl-mapper worked fine. We needed more accurate map in indoor, so we disassembled VOXL Flight Deck and replaced Hi-Res camera with PMD ToF Sensor from VOXL CAM. However, from that point, connecting through ADB doesn’t work.

    To resolve this problem we tried reflashing by fastboot.

    1. Fastboot mode by pressing SW1 for 30 secs.
    2. $ fastboot device
    3. $ sudo ./install.sh -f
    

    Flashing finished but doesn’t do anything but only printing “Waiting for ADB”. adb devices couldn’t detect any device.

    What we have checked:

    1. Reflashing using Fastboot
    2. Power
    • Using Gens ACE 3S, 60C, 5000mAh and Sentinel’s power module
    1. Cable
    • Using USB A to C, wasn’t causing problem before.
    • Connecting cable after 10 secs. powering.
    1. Environment
    • Tested through variety of devices(PC, laptop, windows, mac, ubuntu)
    1. lsusb
    • Detects usb to “Qualcomm, Inc~”
    1. adb
    • Version 1.0.39
    • Tried adb kill-server

    How can we connect through ADB? Thanks.


  • Dev Team

    @darwin-keem sorry to hear you're having issues. You may want to check the camera connections again. If one of the camera connections is not fully seated, it'll prevent full boot of the VOXL2.
    You mentioned that you plugged in the TOF. That might be the cause. Unfortunately, TOF is not yet fully supported on the VOXL2. We'll keep you posted when it does.


  • Dev Team

    @darwin-keem What's the whole output of what it shows up as in lsusb ? It's possible it has been bricked, in which case you will need to use the "QDL" tool in order to get it going again: https://docs.modalai.com/voxl2-qdl/



  • @tom This is the full output of lsusb.

    Untitled.png



  • @Adrian-Hidalgo We disconnected ToF and reconnected with the original Hi-Res camera. Also, we've checked the camera connections, but had no issue about it. However, we've disconnected GPS module, as we don't need it. Can this be the reason?



  • @tom We've ran factory reset with qdl and this is the output.

    Untitled-2.png

    After performing qdl, if we run lsusb without turning off the power, it gives us this.

    Untitled-3.png

    If we cycle power and run lsusb, it is still shown below. It is not recognized as 05c6:901d.

    Untitled-4.png


Log in to reply