QVIO not working



  • Hi,

    Unfortunately we can't get QVIO to work, voxl-inspect-qvio gives 0 position values and jumps between OKAY and FAIL.
    Additionally, after we reset the drone by flashing the factory image we no longer see the "Pointclouds" tab in the portal. How do we enable this again?
    I would appreciate any tips on how to solve this.


  • Dev Team

    It is likely you need to configure the system after reflash. See voxl-configure-mpa



  • Thanks for the hint, qvio is now showing correct positions.
    However, pointcloud is still not available in the portal, how to enable that again?


  • Dev Team

    The pointcloud functionality in voxl-portal is only available through the dev repo right now. To upgrade your current installation, you can run:

    voxl-configure-opkg dev
    

    to point opkg towards our dev repository, and upgrade using:

    opkg upgrade voxl-portal
    


  • Thanks,

    I had to upgrade other packages as well due to dependency constraints. I wasn't able to resolve all of them cleanly because it looks like opencv and voxl-opencv are both required by different packages.

    Unfortunately now the flight control interface seems to be broken, reporting:

    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_insert_pc, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_insert_pc, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_insert_pc, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_insert_pc, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    

    But at least pointclouds are showing now.



  • Additionally, I am unable to view the pointcloud in RViz 😕
    It connects and can show images but not spatial data:

    No tf data.  Actual error: Fixed Frame [map] does not exist
    

    Maybe there is a misconfiguration of ros on the seeker?


Log in to reply