libxslt and libxml with Python



  • Hello,
    I got voxl-python_3.6.9 built and installed on voxl, and am working through pip installing some packages, pymavlink in particular. I see that a couple of libxml packages exist on VOXL, however there are none for libxslt, and opkg can't seem to find an xslt package (I've tried a bunch of combinations like libxslt, libxslt-dev, libxslt-devel, libxslt1, etc.). I also tried installing something like python3-lxml per google searches, but to no avail.

    Is there a way around this, or a way I can point opkg to another repository that has the libxslt package? Thanks.



  • For reference, here is the output.

    yocto:/# pip3 install pymavlink
    Collecting pymavlink
      Using cached https://files.pythonhosted.org/packages/5f/4e/985824701e53ec259d3898eb71c4d9211e643dd986ce74b8c71a32d6437c/pymavlink-2.4.15.tar.gz
    Collecting future (from pymavlink)
      Using cached https://files.pythonhosted.org/packages/45/0b/38b06fd9b92dc2b68d58b75f900e97884c45bedd2ff83203d933cf5851c9/future-0.18.2.tar.gz
    Collecting lxml (from pymavlink)
      Using cached https://files.pythonhosted.org/packages/e5/21/a2e4517e3d216f0051687eea3d3317557bde68736f038a3b105ac3809247/lxml-4.6.3.tar.gz
        Complete output from command python setup.py egg_info:
        Building lxml version 4.6.3.
        Building without Cython.
        Error: Please make sure the libxml2 and libxslt development packages are installed.
        
        ----------------------------------------
    Command "python setup.py egg_info" failed with error code 1 in /var/volatile/tmp/pip-install-loh5dpgv/lxml/
    You are using pip version 18.1, however version 21.0.1 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.
    
    


  • If you can use a Docker container for you application then you can run Ubuntu or Alpine and get access to a lot of packages. If you run on target without a container then you are much more limited in what you can do to resolve dependencies. opkg isn't like apt-get where you can point to large package repositories to find your missing dependencies. In this case you will likely have to build and install libxslt yourself.


Log in to reply