Voxl not connecting to QGC



  • Hello,

    I have gone through the quickstart process and can ssh into my voxl m500 drone, but it does not automatically connect to QCG. I installed qcg using the instructions here for Linux. I am on Ubuntu 20.04. My desktop has two ethernet ports and a wifi card. I tried following the steps in this forum post, but it does not appear to be helping.

    I tried running with the default voxl-vision-px4 and I tried setting up a new one with voxl-configure-vision-px4. I've tried with my ethernet connection both enabled and disabled. In the forum post I linked above, the solution was to input the ethernet ip into the voxl-vision-px4 config, but this does not make sense to me as the connection is happening over wifi. However, I tried with both the ethernet and the wifi ip's of my desktop. In all cases I reset the system with systemctl restart voxl-vision-px4 and have also tried power cycling my desktop.

    Desktop Wifi IP
    desktop_ip.png
    VOXL with WIFI IP
    voxl-ip.png
    Desktop ethernet IP
    desktop ethernet ip.png
    VOXL with ethernet IP
    voxl-ethernet-ip.png
    I have also checked the QCG debugging steps here, and do not have any of the connection messages in the QCG console log, however I am able to connect from my computer to the drone over ssh and wifi.

    Please let me know if there is any other information that can be useful for debugging.

    Cheers,

    Pawel


  • Dev Team

    Hi @PawelJ

    Can you try power cycling your drone and then providing the output of systemctl status -l voxl-vision-px4


Log in to reply