Voxl stuck in waiting for device after unbricking



  • Hey, my voxl is stuck in waiting for device after trying to unbrick it with the addon board. I tried basically everything and followed the instructions precisly and tried power cycling it etc. Some help on what to do would be appreciated 🙂

    sudo ./install.sh -f
    [INFO] adb installed
    [INFO] fastboot installed
    
    [INFO] Factory Mode
    
    [INFO] Using factory mode
    [INFO] Rebooting into fastboot...
    error: no devices/emulators found
    target reported max download size of 536870912 bytes
    sending 'aboot' (494 KB)...
    OKAY [  0.047s]
    writing 'aboot'...
    OKAY [  0.069s]
    finished. total time: 0.116s
    target reported max download size of 536870912 bytes
    sending 'boot' (56070 KB)...
    OKAY [  1.639s]
    writing 'boot'...
    OKAY [  0.416s]
    finished. total time: 2.055s
    target reported max download size of 536870912 bytes
    erasing 'system'...
    OKAY [  0.013s]
    sending sparse 'system' 1/4 (522964 KB)...
    OKAY [ 17.077s]
    writing 'system' 1/4...
    OKAY [ 13.870s]
    sending sparse 'system' 2/4 (521547 KB)...
    OKAY [ 21.430s]
    writing 'system' 2/4...
    OKAY [ 14.420s]
    sending sparse 'system' 3/4 (524111 KB)...
    OKAY [ 21.710s]
    writing 'system' 3/4...
    OKAY [ 15.434s]
    sending sparse 'system' 4/4 (76257 KB)...
    OKAY [  3.667s]
    writing 'system' 4/4...
    OKAY [  4.348s]
    finished. total time: 111.969s
    target reported max download size of 536870912 bytes
    erasing 'userdata'...
    OKAY [  0.024s]
    sending 'userdata' (142611 KB)...
    OKAY [  4.099s]
    writing 'userdata'...
    OKAY [  1.172s]
    finished. total time: 5.295s
    target reported max download size of 536870912 bytes
    sending 'persist' (4292 KB)...
    OKAY [  0.177s]
    writing 'persist'...
    OKAY [  0.070s]
    finished. total time: 0.247s
    target reported max download size of 536870912 bytes
    erasing 'cache'...
    OKAY [  0.021s]
    sending 'cache' (5152 KB)...
    OKAY [  0.217s]
    writing 'cache'...
    OKAY [  0.095s]
    finished. total time: 0.332s
    target reported max download size of 536870912 bytes
    sending 'recoveryfs' (126585 KB)...
    OKAY [  3.532s]
    writing 'recoveryfs'...
    OKAY [  6.273s]
    finished. total time: 9.805s
    [INFO] Done flashing all images. Rebooting device in 2 seconds
    rebooting...
    
    finished. total time: 0.072s
    [INFO] Waiting for device...
    
    
    


  • Are you able to communicate with other devices using ADB?

    Have you tried 'adb kill-server' to make sure it's not a stale ADB session?

    Are you supplying enough current for the board to boot? If you use ModalAI's Power Adapter you should be fine. If it's custom, sometimes not enough current is provided.



  • I'm just gonna leave this here if it affects others aswell:
    I was stuck on the issue for a while but it was indeed an adb issue. Restarting it didn't fix the issue and I couldn't debug what the problem seems to be. Using another device (laptop) did work tho and I was able to unbrick it.
    Thanks for the inputs Chad.


Log in to reply