Position Mode Rejected



  • Hi,
    I tried the voxl-cam for the first time and all seems to be working fine except that px4 is not getting into position mode.

    voxl-inspect-qvio prints reasonable poses, I can see the Odometry topic in QGC with 30 hz with x,y values not zero.

    My EKF2_AID_MASK is 280 and with the same parameters and the voxl flight-deck I managed to start in position mode without GPS attached.

    Problem seems to be that I cannot get values in LOCAL_POSITION_NED and nothing is being output on uorb top vehicle_visual_odometry in a nuttx console.

    I made a cable to connect the pixhawk4 and the voxlcam, which is twice as long as in the old setup. The voxl-vision-px4 systemd service suggests that UART is connected, but maybe there could be some issue in sending the data?

    Do you have any suggestions?

    Thanks!


  • Dev Team

    Which version of PX4 are you running on the Pixhawk and do you have a magnetometer connected? EKF2 is generally unhappy about about starting without a magnetometer in PX4 1.11 so we patched the PX4 firmware for Flight Core to get around this. In PX4 1.12 and newer the following PX4 parameter can be set to allow EKF2 to allow position mode without a GPS/Mag

    ## disable mag
    SYS_HAS_MAG	0	
    EKF2_MAG_TYPE	5