Microhard failing to connect



  • Hello, I think I have a question for @tom

    We are using a voxl-flight with a microhard add-on board with a pDDL900 in the socket.

    The symptoms we are seeing is the modem booting up correctly sometimes and after running dmesg we see errors related to wcd9335. It seems like a conflict with usb devices but we aren't sure.

    Here is the dmesg for more information.
    https://flyvoly-my.sharepoint.com/:t:/p/bgrocholsky/EfsK-HaEl8BKtn2yXtPQFoAByGDu8L2SYYkdEOCTN-Vz6A?e=I09nMp

    Is this a known issue? Can you replicate this on your end? Is there a workaround?

    Hope to hear from you soon,
    Eli


  • Dev Team

    Hi @evigdorchik we'll try to replicate over here, thanks for the data. It's not something we've heard of yet but we'll see how things look on our rack. If you can provide what system image etc that could help us replicate.

    There's a few folks out on holiday right now so responses are a little delayed.



  • The system image is 3.3.0 with 0.5.0 voxl suite. Just downloaded and flashed the latest one from the developer resources page before this test.



  • Hey @modaltb this seems to be an intermittent thing that stops working at inconsistent intervals. It seems like something triggering the ifconfig to be deactivated on eth0. We are currently testing it with dhcp disabled on the modems and commented out "dhcpcd eth0" in /etc/initscripts/setup_ethernet.sh

    Let me know what you guys find. Maybe brainstorm anything that might cause an intermittent reset on eth0? Is seems to boot up correctly then die

    Happy Holidays!



  • Hello,
    Any followup on this?


Log in to reply