avahi not working



  • Hi, I've flashed modalai-3-2-0-0.2.0.tar.gz (sys img and voxl suite) which has avahi 0.6.32

    root@HX88~ $ avahi-daemon --version
    avahi-daemon 0.6.32
    

    but can't ping my hostname.local:

    root@HX88~ $ systemctl status avahi
    ● avahi-daemon.service - LSB: Avahi mDNS/DNS-SD Daemon
       Loaded: loaded (/etc/init.d/avahi-daemon)
       Active: inactive (dead)
         Docs: man:systemd-sysv-generator(8)
    root@HX88~ $
    root@HX88~ $ systemctl start avahi
    root@HX88~ $
    root@HX88~ $ systemctl status avahi -l
    ● avahi-daemon.service - LSB: Avahi mDNS/DNS-SD Daemon
       Loaded: loaded (/etc/init.d/avahi-daemon)
       Active: active (running) since Fri 2021-04-30 14:58:34 UTC; 2s ago
         Docs: man:systemd-sysv-generator(8)
      Process: 3496 ExecStart=/etc/init.d/avahi-daemon start (code=exited, status=0/SUCCESS)
       CGroup: /system.slice/avahi-daemon.service
               └─3501 avahi-daemon: running [HX88.local]      
    
    Apr 30 14:58:34 HX88 systemd[1]: Starting LSB: Avahi mDNS/DNS-SD Daemon...
    Apr 30 14:58:34 HX88 avahi-daemon[3496]: * Starting Avahi mDNS/DNS-SD Daemon: avahi-daemon
    Apr 30 14:58:34 HX88 avahi-daemon[3501]: avahi-daemon 0.6.32 starting up.
    Apr 30 14:58:34 HX88 avahi-daemon[3501]: Loading service file /etc/avahi/services/multi.service.
    Apr 30 14:58:34 HX88 avahi-daemon[3501]: Network interface enumeration completed.
    Apr 30 14:58:34 HX88 avahi-daemon[3501]: Server startup complete. Host name is HX88.local. Local service cookie is 1523486884.
    Apr 30 14:58:34 HX88 systemd[1]: Started LSB: Avahi mDNS/DNS-SD Daemon.
    Apr 30 14:58:34 HX88 avahi-daemon[3501]: Service "9x25 MobileAP MDNS" (/etc/avahi/services/multi.service) successfully established.
    Apr 30 14:58:34 HX88 avahi-daemon[3496]: ...done.
    root@HX88~ $
    root@HX88~ $ hostname
    HX88
    root@HX88~ $
    root@HX88~ $ ping HX88.local
    ping: unknown host HX88.local
    

    any hints?



  • Were you able to get this working? If not, we can take a look again.



  • this is still an issue after trying voxlplatform_3.3.0

    however, uninstalling avahi (opkg remove avahi and dependents) and install using https://gitlab.com/voxl-public/other/install-avahi works


Log in to reply