Odometry Not working properly

  • Hello,
    I have been testing voxl for a while everything was working properly. But in one flight drone odometery started showing unusual readings.

    I was flying the drone in manual mode and it flew properly. Than I landed the drone and switched to position mode and started to monitor the odometery in QGroundControl and in mavros. When the drone is not armed the odometery value are near to 0 which is correct . But as soon as it is armed The odometery gets haywire. The drone is just armed and is on the ground but orometery show it is 40meters in the air or sometimes is below ground and the values keep on increasing.

    I re-calibrated the drone's optical flow sensor as well as the imu but the problem still persist.

    Than I tried the dry run just turning on the voxl and lifting up the drone with the hand and moving around. for reasons unknown the odometery works properly.
    So I tried it again to arm the drone and watch the odometery and its started to act weirdly again.

    If anyone have any clue why is it acting like this or might have encountered similar problem please do help.
    Any input is appreciated.

  • That sounds like a vibration issue. Has.l anything changed mechanically?

    A good way to debug vibration is to look at the px4 logs. If you upload to review.px4.io there are nice IMU vibration graphs

  • We have been testing on the same configuration for a while and never had that problem. We tried with position mode and off-board mode as well everything worked fine and have not made any changes in configuration.

    Enclosed is the log of the recent flight. We might be missing something. Your insight is needed


  • Dev Team

    Hi @abdullah ,

    Was the PX4 FW version changed at any point? We have seen some performance issues with PX4 1.11 and the position controller. I see in your logs you have v1.11.2 going.

    Is there anyway to load the ModalAI 1.10 FW as a data point and see if the flight performance changes?



  • This post is deleted!