Cannot connect rb5 with VOXL SDK to QGC



  • Hello,

    We recently flashed our 5G LTE rb5 drones with system image RB5 Platform 1.3.1-0.8 (https://developer.modalai.com/asset/3) but have been experiencing issues when trying to connect to QGC.

    First (after putting the drone into softap mode), we ran voxl-configure-vision-px4 and enabled everything but offboard mode. We use the ip of the laptop connected to the drone's network as our input for QGC ip address

    Second, when we run voxl-inspect-services, we see voxl-vision-px4 is enabled but not running. If we try "systemctl start voxl-vision-px4," it immediately crashes. Attached is the output of "systemctl status voxl-vision-px4."
    Screen Shot 2022-09-09 at 6.07.16 PM.png

    Third, we tried running voxl-configure-mavlink-server and enabled permissions, then tried running voxl-configure-vision-px4, but this had the same result.

    We couldn't find any specific documentation on how to connect a rb5 VOXL SDK drone to qgc, so any help you could give would be welcome.


  • Dev Team

    @Daniel-Ryu Would it be correct to say that you've already configure mpa? Looking at the output from voxl-inspect-services, it looks like mpa hasn't started.
    Might want to try that out if you have't already did



  • @Adrian-Hidalgo That was it, thanks!


Log in to reply