Propellers not Spinning / Calibration Issues

  • I am working with the VOXL Flight Deck building a hexacopter and testing it without propellers.

    On Q Ground Control, I can arm the hexacopter, however when I throttle it using virtual joystick, the motors do not respond. Furthermore, when it is armed the motors are not spinning.

    What is causing this issue?

    Furthermore, I tried to calibrate the ESCs as per this guide:

    I get to this prompt

    You should hear a second jingle.
      Wait for the second calibration jingle to complete.
      After the second jingle stops, press [ENTER] to proceed

    However there is no second jingle.

  • Dev Team

    @alfa-budiman sorry to hear you're having problems. Let's see what we can do to resolve this.
    Want to clarify some things if you don't mind. In QGC(Q-Ground-Control) you've already set the frame to the hex?
    What version is your software?
    What motor and esc combo are you using?
    How are you connecting the esc's to the VF(Voxl-Flight)?
    From what you mentioned in attempting to calibrate the esc's, it sounds like esc's aren't talking with the VF. Are they PWM or DShot capable?

  • Dev Team

    Please confirm you have a battery connected and NOT a wall supply

  • This post is deleted!

  • @Adrian-Hidalgo
    Want to clarify some things if you don't mind. In QGC(Q-Ground-Control) you've already set the frame to the hex?

    • Yes

    What version is your software?

    • 1.11.3

    What motor and esc combo are you using?

    • ESCs: Readytosky 2-6S 40A Electronic Speed Controller

    • Motors: FlyCat HRotor 5010-360KV

    How are you connecting the esc's to the VF(Voxl-Flight)?

    • PWM breakout board that came with the VOXL Flight Deck.

    From what you mentioned in attempting to calibrate the esc's, it sounds like esc's aren't talking with the VF. Are they PWM or DShot capable?

    • I'll confirm and get back to you on this.

    I am using a battery and not a wall power supply.

  • Some more info that may help:

    from mavlink shell on QGC:
    pwm info with drone disarmed:

    pwm info with the drone armed:

    The ESCs are PWM capable

  • Dev Team

    Thanks for the information! We're looking into it and will get back to you.
    Can you spin the motors in the terminal of QGC using either:
    "pwm test -c 1 -p 1100" --> c designates which motor
    "motor_test test -m 0 -p 15" ? --> m designates which motor

    When you plug in the battery, do the esc make a chime?

  • @Adrian-Hidalgo
    I cannot spin the motors in terminal of QGC using the commands you provided. I tried different variations of them too and the motors do not spin. I also tried Motors Setup and it just says "Vehicle did not respond to command MAV_CMD_DO_MOTOR_TEST"

    I tried them with different options as well:

    The ESC does indeed make a chime when the battery is plugged in.

    I have a question - is it possible that some of the parameters I set on Q Ground control could result in my issue? Notably I should point out that I am using local_position_estimator for SYS_MC_EST_GROUP.

    I have also tried changing PWM_MAIN_MAXn to 2000 and PWM_MAIN_MINn to 1000, where n is 1 to 6. I tried setting it to other values as well, This didn't work either.

  • I tried resetting the params, re-calibrating the sensors and using ekf2 for SYS_MC_EST_GROUP. I followed the instructions here:

    I should also note that I am working with two seperate VOXL Flight decks and have ran these tests on both of them, using both sets of params* and have the same result - which is that the motors do not spin.

    *One set of params was from following your instructions - using the ek2_indoor_vio.params, the other set was one I put together myself thru trial and error, which used local_position_estimator.

    Again, I tried manually changing PWM_MAIN_MAXn to and PWM_MAIN_MINn on both VOXL Flight Decks and the motors do not spin.

    I tried calibrating ESCs as per your instructions, on both wired and wireless methods:

    This part is good to go

    This part is an issue, I wait a few minutes and there is no second jingle

  • Overall, the problem is something that effects all ESCs or all the motors. It is unlikely that all 6 ESCs and all 6 motors are broken, if faulty parts are an issue (but everything else was good to go) then the properly functioning motors/ESCs would spin while the broken ones wouldn't. It's also unlikely that all the wiring between the VOXL Flight and all 6 ESCs would be improper.

    If the issue is related to the physical components, I beleive it would be one of the following:

    • the brand of motor is incompatible
    • the brand of ESC is incompatible
    • the breakout board is faulty
    • the connection from the breakout board to the VOXL Flight deck is faulty
    • PWM output on VOXL Flight Deck is faulty (J1007). Unlikely as I have two VOXL Flight Decks. Furthermore, I have done the following:
      1 - disconnect PWM from VOXL Flight Deck. ESCs remain connected to power distribution
      2 - connect drone to battery - ESCs chime
      3 - while the drone is powered up, I connect PWM to VOXL Flight Deck via J1007. The ESCs chime again, coinciding with making that first jingle in the calibration process.

    However, since the issue effects all ESCs / motors, a software issue, or an issue with the VOXL Flight Decks is a possibility. I think hardware issues with the VOXL Flight Deck is unlikely as I have tested two of them.

    As for software issues, this could be PX4 version or QGround Control parameters, or something else. But I have no indication to tell me that the PX4 version or QGC params are the issue, I've tested two different sets of parameters; and on QGC the heading and artificial horizon respond as expected when I move the drone. I genuinely have no idea what to do next if it is a software issue.

    The only other hint I have is the problem with calibration. I also do not think it is a battery / power issue, I tested it with a full battery, motors still don't spin.

  • Additional testing with pwm info:

    It does appear to be attempting to adjust PWM signal as I throttle the drone on virtual joystick:


    One possible theory - the ESC / motors need more PWM then what can be provided by QGC / VOXL Flight Deck. The max PWM it can provide is around 2100, even if the I set PWM_MAIN_MAX to 4000, it doesn't provide more than approx 2100. I'm certain that PWM_MAX_MAIN is the correct setting, as when I set this to 1600, and check pwm info, the PWM at max throttle is around 1600.

  • Dev Team

    Hi @alfa-budiman ,

    It looks like PWM_MAX in PX4 has a range from 1600 to 2200....



    and master still:

    Are you positive the ESC needs a 4000us?? I've not heard of that before 🤔

  • @modaltb
    I'm not positive that the ESC needs 4000. I just put that setting on QGC to test what would happen. I'll have to check the ESC documentation to verify its PWM range.

  • Dev Team

    @alfa-budiman it may be possible that how the esc's are plugged into the breakout board are flipped. Signal is on top, ground is on the bottom.
    Could you send a couple of high-resolution pictures of the setup?

  • Dev Team

    @alfa-budiman Good morning, please try reversing all six pwm connections coming from the escs to the breakout board.
    Your photo shows them plugged in with incorrect pinout.
    This will definitely cause all of the problems you're describing. Thanks and good luck.

  • Dev Team

    @alfa-budiman And I would also suggest going back into QGC and configuring the PWM related params back to their defaults. Once the polarity of the PWM's are correct, you should be able to calibrate successfully.

  • Thanks. I got it working and it appears to be calibrated. It also appears to be responding as intended with MAVROS when I publish to /mavros/setpoint_velocity/cmd_vel_unstamped

    I tested with props off and powered via battery. I published 0,0,1,0 corresponding with vertical speed of 1 m/s up and the motors sped up. I then published 0,0,-1,0 and the motors slowed down as expected.

Log in to reply