Unable to calibrate ESCs

  • Hi all
    I am have two drones with the VOXL flight deck.

    Drone 1 (250mm) is running a T-motor F45 V2 ESC. I am unable calibrate the esc. I have followed the documentation mentioned on website.
    I dont hear any jingles as such. The only tone I get is the esc being powered on and that is it. No jingles as one would except when doing esc calibration.
    I tested the drone on my bench and the whole drone vibrates violently and the motors get hot within a 5 second run. Not sure what am I doing wrong!
    I had done the esc calibration previously with my other voxl flight deck which got damaged (camera cable) on this same drone and everything worked perfectly!
    Thinking it maybe an issue with the 2nd voxl flight deck, I tried the esc calibration with a 3rd VOXL flight deck and same issue as the second one.

    Drone 2 (650mm) is running Xrotor 40A and i am having same issues like drone 1.

    Could surely use some help on this!

    Thank & Regards,
    Mohammed Naveed

  • Dev Team


    You shouldn't need to calibrate those esc's as long as you have "Dshot" enabled in the QGC parameters.

    The parameter you're looking for is "DSHOT_CONFIG"

    Enable the dshot speed that best fits your ESC specs and after that you'll want to verify all motor ordering and directions before flight.

    Here's a link with more information https://docs.px4.io/master/en/peripherals/dshot.html

  • Hi @Jeremy-Schmidt
    Thanks for your input!
    Not sure what happened overnight but I was able to successfully calibrate the ESC as per the voxl documentation. I got both the jingles.
    But the drone is still violently vibrating and the motors still get hot after 5 seconds of run!

  • My motors have also been vibrating violently, one of them has a higher throttle threshold than the other 3, tends to vibrate more and gets considerably hotter than the other ones, so I'd like to hear the dev team's thoughts on this issue as well.

  • Hi all
    Just an update on this.
    I flew the drone with a 3s lipo as this was what I was using before. It flew like a charm no issues. The dshot config was disabled and set to default (PWM) for the 3s lipo.
    Now coming to the 4s regardless of whether its PWM or dshot 1200 I am getting these bad oscillations on the drone. The drone can fly and maintain altitude but the oscillations are too much. I see the oscillations in the roll axis and oh boy the motor really gets hot. In 1 min flight i almost burned my hand picking up the drone.
    Any thoughts what could be the issue? I am thinking its something to do with tuning the parameters.
    I will share my ulogs tomorrow.

    Setup used:
    Motors : Emax RS2306 2400KV
    ESC: T-motor F45 V2.0 4 in 1
    Prop: Gemfan 5.1 x 4.99 x 3 hurricane
    Lipo: 4s 1550mah 100c

    Thanks & Regards,
    Mohammed Naveed

  • Please have a look at the Ulogs

    3s Flight Ulog

    4s Flight Ulog

    Is there anything else i should a keep an eye for?

    Thanks & Regards,
    Mohammed Naveed

Log in to reply