m500 firmware update



  • Hi team,

    I am trying to update the firmware using the latest v1.11.3-0.2.3, but I got some questions. I am following the instruction by this link:
    https://docs.modalai.com/update-flight-core-firmware/

    I use MCBL-00010 with microUSB cable to connect the PC with QGC. After this, the instruction says "Power cycle the Flight Core or VOXL Flight (the bootloader runs and the green LED flashes quickly)", does the "power cycle" mean that I should use QGC to reboot the drone or anything else?

    I tried to reboot the drone, then get back to the firmware tab in QGC while USB is connecting, but it shows an error log:

    Error: Open failed on port cu.usbmodem01: Permission error while locking the device
    Upgrade cancelled
    ------------------------------------------
    If upgrade failed, make sure to connect directly to a powered USB port on your computer, not through a USB hub. Also make sure you are only powered via USB not battery.
    

    I am confused about this, and why it says only powered via USB not battery? I tried to turn off the battery, but nothing happened in QGC and showing disconnected.

    I am trying to fix the GPS no LED flash issue by updating firmware. So, please any advice on this issue?

    Thanks.


  • Dev Team

    Hi,

    Do you already have the new firmware downloaded? If so, power up the drone with usb connected.
    Connect to QGC and navigate to the firmware tab.

    At this point you want to power cycle the drone and when it comes back up in QGC you should see the window pop up which allows you to choose which firmware to select.

    I believe our videos will show you the rest of the process. Let me know if you run into problems.


  • Dev Team

    @yu-zhang said in m500 firmware update:

    Error: Open failed on port cu.usbmodem01: Permission error while locking the device
    Upgrade cancelled

    It looks like you have an OS permission issue that's locking the device. Take at look at how you setup QGC and the USB device on your Mac.

    As for the firmware upgrade and power, on other PX4 controllers you need to only power the controller via USB. In our setup, there's only one power source and you cannot power via USB. Thus you use the main battery supply as documented in the link above to power cycle.



  • Hi @Jeremy-Schmidt , I got it, and I already completed the update. I disordered the instruction before. Now, it works well and GPS led works again. Thanks!



  • Hi @RichieRich , I fixed the issue as I disordered the instruction. Anyways, thanks so much 😉


Log in to reply