Can I control the drone through 5G (No Spektrum Transmitter) ?

  • Or the 5G is only for viewing the camera?

  • Dev Team

    Yes, the tool is QGroundControl. You can find documentation here on how to control the drone over 5G.

  • Hi Chad,

    Thanks for the directions.

    I was going through the initial setup and I'm stuck at the point to connect to QGroundControl.
    I'm at the same NW as the drone but when I check the status for the P4X it shows the following:

    sh-4.4# systemctl status rb5-px4-start
    ā— rb5-px4-start.service - rb5-px4-start
       Loaded: loaded (/etc/systemd/system/rb5-px4-start.service; enabled; vendor pr
       **Active: inactive (dead)**
    lines 1-3/3 (END)

    I've tried disabling/enabling and rebooting but I still could not see the drone on the QGC app..

    Wifi is now up and running:

    sh-4.4# ifconfig wlan0
    wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet  netmask  broadcast
            inet6 fe80::34d3:41a2:d468:53d2  prefixlen 64  scopeid 0x20<link>
            ether 00:03:7f:12:d8:ac  txqueuelen 3000  (Ethernet)
            RX packets 837  bytes 50588 (50.5 KB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 849  bytes 62391 (62.3 KB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

    Let me know if any further configuration is necessary to have it available to connect on QGC.

  • Dev Team

    @Francesco-Jacomel rb5-px4-start relies on rb5-net-check to finish before starting. You will want to modify /etc/systemd/system/rb5-net-check.service to fit your network.

    If you take a look at the the service file:

    ExecStart=/usr/bin/rb5-net-check wlan0 192.168

    By default it waits until wlan0 is assigned an IP address of the form 192.168
    For your use case it looks like you will want to change this 192.168 to 10.188 in order for the net check to pass and for px4 to start.

  • Dev Team

  • @tom said in Can I control the drone through 5G (No Spektrum Transmitter) ?:


    Thank you @tom ! It worked!

Log in to reply