Can't ping in station mode and can't re-enable modem

  • All in the adb shell, I was trying to pull the docker image for the C++ SDK when I kept getting the following error:
    Error response from daemon: unable to ping registry endpoint
    v2 ping attempt failed with error: Get dial tcp: lookup on [::1]:53: server misbehaving
    v1 ping attempt failed with error: Get dial tcp: lookup on [::1]:53: server misbehaving

    I assumed the board had failed to connect to the internet so I again tried entering station mode with a different SSID of another working network, rebooting as needed. Neither of the networks I tried are password protected if that's important.

    I've tried several trouble-shooting tactics mentioned here on the forums including various combinations of [ifconfig docker0 down] and [ifconfig wlan0 down] and then the corresponding [...up] commands when those failed to yield better results. I also used [systemctl disable voxl-modem] and rebooting then trying to ping and and failed at both, getting "unknown host" messages. I then tried using [systemctl enable voxl-modem] and was returned "Failed to execute operation: No Such File or directory."
    Between all my trouble shooting steps I've tried pinging and
    with no avail.
    The drone was handed to me as a project at work. I thought I was working with an m500 but my ifconfig response in the adb shell doesn't show a "eth0" like the m500's seem to based one what I've noticed in the forums. The board I'm working with has "MODAL AI M0019-REV B" printed on one of the edges forming the triangular point at one end.

    Help me re-enable my modem and get VOXL connected to internet, please. Thanks!

  • Dev Team

    Hi @jskard ,

    Thanks for the details. I'm not positive what's happening here, but first:

    • password protection on network shouldn't matter, but most of our test scenarios have passwords (we'll validate this over here)
    • what modem are you using? LTE or Microhard?


Log in to reply