Can't ping in station mode and can't re-enable modem

  • All in the adb shell, I was trying to pull the docker image for the C++ SDK when I kept getting the following error:
    Error response from daemon: unable to ping registry endpoint
    v2 ping attempt failed with error: Get dial tcp: lookup on [::1]:53: server misbehaving
    v1 ping attempt failed with error: Get dial tcp: lookup on [::1]:53: server misbehaving

    I assumed the board had failed to connect to the internet so I again tried entering station mode with a different SSID of another working network, rebooting as needed. Neither of the networks I tried are password protected if that's important.

    I've tried several trouble-shooting tactics mentioned here on the forums including various combinations of [ifconfig docker0 down] and [ifconfig wlan0 down] and then the corresponding [...up] commands when those failed to yield better results. I also used [systemctl disable voxl-modem] and rebooting then trying to ping and and failed at both, getting "unknown host" messages. I then tried using [systemctl enable voxl-modem] and was returned "Failed to execute operation: No Such File or directory."
    Between all my trouble shooting steps I've tried pinging and
    with no avail.
    The drone was handed to me as a project at work. I thought I was working with an m500 but my ifconfig response in the adb shell doesn't show a "eth0" like the m500's seem to based one what I've noticed in the forums. The board I'm working with has "MODAL AI M0019-REV B" printed on one of the edges forming the triangular point at one end.

    Help me re-enable my modem and get VOXL connected to internet, please. Thanks!

  • Dev Team

    Hi @jskard ,

    Thanks for the details. I'm not positive what's happening here, but first:

    • password protection on network shouldn't matter, but most of our test scenarios have passwords (we'll validate this over here)
    • what modem are you using? LTE or Microhard?


  • This post is deleted!

  • Hey @modaltb

    Thank you for the response! I believe I'm using the Microhard modem, but just to be sure, could you tell me how I can verify that, presumably within the adb shell?

  • Dev Team

    Microhard is a point to point radio, so it won't connect to the internet.

    The 'ifconfig' command is used in Linux to see what network interfaces are up and running. Can you share the output of that command here?

  • @Chad-Sweet

    docker0 Link encap:Ethernet HWaddr 02:42:2B:2F:08:D2
    inet addr: Bcast: Mask:
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    lo Link encap:Local Loopback
    inet addr: Mask:
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:50873 errors:0 dropped:0 overruns:0 frame:0
    TX packets:50873 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:3919208 (3.7 MiB) TX bytes:3919208 (3.7 MiB)

    wlan0 Link encap:Ethernet HWaddr EC:5C:68:CD:24:BD
    inet addr: Bcast: Mask:
    inet6 addr: fe80::ee5c:68ff:fecd:24bd/64 Scope:Link
    RX packets:8863 errors:0 dropped:0 overruns:0 frame:0
    TX packets:28646 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3000
    RX bytes:659524 (644.0 KiB) TX bytes:2228956 (2.1 MiB)

  • Dev Team

    @jskard Can you share an image of your drone showing the modem that is attached? That’ll be the easiest way for us to determine what you’re working with.

  • @tom Thanks for the response. The issue has been resolved. I successfully pinged google after trying this on my home network (WPA2-Personal security type), I'm guessing the issue was with the security type of my firm's network that I had been trying to connect to originally.

    As for the modem issues, after familiarizing myself more with the hardware I realized I hadn't attached the VOXL LTE modem that came with my kit which probably explains why a disabling command worked and an enabling command gave me a failure message. I had incorrectly assumed the modem of concern was already onboard the flight core. Thanks to the dev team and @Chad-Sweet for your responses.

Log in to reply