LTE - Modem Works But Cannot Ping


  • Dev Team

    @vmassague Are you using the LTE V2 Add-on or Stand Alone? And you're using the Sierra 7607 modem correct?



  • @tom, I am using the add-on



  • @tom I'm using the Add-on also and I'm using the Sierra 7607


  • Dev Team

    @derrick0799 Can you disable the voxl-modem service from running with systemctl disable voxl-modem and reboot your voxl.

    Then run voxl-modem-start.sh manually so I can see the full output?


  • Dev Team

    @vmassague Can you disable the voxl-modem service from running with systemctl disable voxl-modem and reboot your voxl.

    Then run voxl-modem-start.sh manually so I can see the full output?



  • @tom, sure. It will be later this evening before I am able to do so.


  • Dev Team

    @derrick0799 @vmassague Another thing for both of you to check is to see if the APN is indeed set correctly, you can do this with the following command:

    / # echo -ne "AT+CGDCONT?\r" | busybox microcom -t 1000 /dev/ttyUSB2
    AT+CGDCONT?
    +CGDCONT: 1,"IP","h2g2","0.0.0.0",0,0,0,0
    +CGDCONT: 2,"IPV4V6","ims","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
    +CGDCONT: 3,"IPV4V6","sos","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,1
    

    In this case, my APN is h2g2 for GoogleFi



  • @tom I ran 'systemctl disable voxl-modem' and reboot voxl then...
    yocto:~$ voxl-modem-start.sh

    VOXL detected...

    Initializing v2 modem...

    Waiting for ttyUSB2...
    ttyUSB2

    Initalizing cellular connection...
    Configuring GPIO to pull modem out of reset
    Waiting for the diag serial port(/dev/ttyUSB0) to activate
    checking for serial port: /dev/ttyUSB0
    /dev/ttyUSB0 is available
    Verifying existence of QMI port(/dev/cdc-wdm0)
    checking for serial port: /dev/cdc-wdm0
    /dev/cdc-wdm0 is available
    Unstick QMI countdown: 10
    Unstick QMI countdown: 9
    Unstick QMI countdown: 8
    Unstick QMI countdown: 7
    Unstick QMI countdown: 6
    "12253379280"
    Checking for system registration
    Attempt: 1
    {
    "registration": "registered",
    "plmn_mcc": 311,
    "plmn_mnc": 480,
    "plmn_description": "Verizon ",
    "roaming": false
    }

    response: [{
    "registration": "registered",
    "plmn_mcc": 311,
    "plmn_mnc": 480,
    "plmn_description": "Verizon ",
    "roaming": false
    }
    ]
    Successfully registered with the network
    Starting network
    "No effect"
    Checking connection status
    Connection is up
    Using the DHCP client to get an IP address
    udhcpc (v1.23.2) started
    Sending discover...
    Sending select for 100.68.239.240...
    Lease of 100.68.239.240 obtained, lease time 7200



  • @tom said in LTE - Modem Works But Cannot Ping:

    echo -ne "AT+CGDCONT?\r" | busybox microcom -t 1000 /dev/ttyUSB2

    yocto:~$ echo -ne "AT+CGDCONT?\r" | busybox microcom -t 1000 /dev/ttyUSB2
    AT+CGDCONT?
    +CGDCONT: 1,"IP","vzwinternet","0.0.0.0",0,0,0,0
    +CGDCONT: 2,"IPV4V6","ims","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
    +CGDCONT: 3,"IPV4V6","sos","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,1

    OK


  • Dev Team

    @derrick0799 Do you have WiFi connected? If so, try disabling it with ifconfig wlan0 down and seeing if you can then ping.

    Also, can I see the output of route -n?

    Same for you @vmassague something to try.


  • Dev Team

    @derrick0799 Looks like APN is setting correctly so that's good



  • @tom after disabling wlan0,
    / # ping 8.8.8.8
    connect: Network is unreachable

    / # route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    172.17.0.0 0.0.0.0 255.255.0.0 U 0 0 0 docker0
    / #


  • Dev Team

    @derrick0799 What does ifconfig show?



  • @tom
    / # ifconfig
    docker0 Link encap:Ethernet HWaddr 02:42:77:DF:4E:80
    inet addr:172.17.0.1 Bcast:0.0.0.0 Mask:255.255.0.0
    inet6 addr: fe80::42:77ff:fedf:4e80/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:140 (140.0 B)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:609376 errors:0 dropped:0 overruns:0 frame:0
    TX packets:609376 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:65142775 (62.1 MiB) TX bytes:65142775 (62.1 MiB)

    / #


  • Dev Team

    @derrick0799 Is that the output after running voxl-modem-start.sh?


  • Dev Team

    At that point, you should be seeing something similar to:

    wwan0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
              inet addr:30.60.23.115  P-t-P:30.60.23.115  Mask:255.255.255.248
              UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
              RX packets:33 errors:0 dropped:0 overruns:0 frame:0
              TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:3214 (3.1 KiB)  TX bytes:4672 (4.5 KiB)
    


  • @tom I think my problem was that the wifi was connected when I ran the voxl-modem-start.sh
    Now that I am connect with adb everything started working when I re-ran voxl-modem-start.sh. It is pinging as it should.



  • @tom
    / # ifconfig
    docker0 Link encap:Ethernet HWaddr 02:42:77:DF:4E:80
    inet addr:172.17.0.1 Bcast:0.0.0.0 Mask:255.255.0.0
    inet6 addr: fe80::42:77ff:fedf:4e80/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 B) TX bytes:140 (140.0 B)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:1472332 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1472332 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:155328799 (148.1 MiB) TX bytes:155328799 (148.1 MiB)

    wwan0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet addr:100.76.95.21 P-t-P:100.76.95.21 Mask:255.255.255.252
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
    RX packets:2 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2713 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:612 (612.0 B) TX bytes:1304344 (1.2 MiB)

    / # ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
    64 bytes from 8.8.8.8: icmp_req=1 ttl=113 time=34.3 ms
    64 bytes from 8.8.8.8: icmp_req=2 ttl=113 time=35.1 ms
    64 bytes from 8.8.8.8: icmp_req=3 ttl=113 time=34.0 ms
    64 bytes from 8.8.8.8: icmp_req=4 ttl=113 time=27.1 ms
    64 bytes from 8.8.8.8: icmp_req=5 ttl=113 time=31.1 ms
    64 bytes from 8.8.8.8: icmp_req=6 ttl=113 time=36.5 ms
    64 bytes from 8.8.8.8: icmp_req=7 ttl=113 time=24.0 ms

    Thanks @Tom


  • Dev Team

    @derrick0799 Great to hear!



  • Problem solved for me too! I think it was also the wlan0 being up. Thanks a lot for the support @tom


Log in to reply