voxl-rtsp started but can't stream with VLC/Qgroundcontrol



  • Finally got time this weekend to get my Flight Deck powered up and connected to QGroundControl, etc. I am having an issue getting video streaming working - I started voxl-rtsp successfully (as per screenshot below:

    Screen Shot 2021-07-05 at 5.11.52 PM.png

    but I wasn't sure if stream url is rtsp://192.168.8.1:8900/live or rtsp://0.0.0.0:8900/live so tried both in VLC and no luck.

    8b91efcf-e871-4dd4-9cc2-732f915c47a6-image.png

    Any ideas?


  • Dev Team

    Hello Mark,

    A few things to check..

    • make sure the voxl-camera-server is not running, since it cannot be used concurrently with voxl-rtsp (you can check what services are enabled using voxl-inspect-services
    • when connecting via VLC, you should not use 0.0.0.0 address. 0.0.0.0 is an invalid address
    • it is strange that voxl-rtsp reports that it's listening on 0.0.0.0. It looks like you have VOXL in AP mode (based on the IP address). Run ifconfig and see if it shows anything strange. The fact that you are able to ssh into VOXL using 192.168.8.1 means wifi AP is working fine..
    • just in case, try using it's actual ip address in the rtsp:// field - it looks like you already tried it in VLC?
    • if you are able, please try compiling and using the latest version of voxl-rtsp here : https://gitlab.com/voxl-public/utilities/voxl-rtsp/-/tree/dev - it will also print some stats after you exit, just making sure the camera frames are actually coming in. There is a script build_in_docker.sh that makes it easier to compile voxl-rtsp, as long as you already have the voxl-emulator docker image

Log in to reply