ADB Device Offline



  • Hi, I am facing the same issue mentioned in post: https://forum.modalai.com/topic/151/adb-device-offline?_=1624343494928

    fbc5fadc-7b05-4f47-a3fa-a93cdd9ab235-image.png
    1c0f5add-e9e9-41bc-90a8-01be8d139afd-image.png

    Please help me to resolve it

    Also, I don't have a USB Expander and Debug Add-On Board (https://docs.modalai.com/usb-expander-and-debug-manual/)
    So is there any other way so we can Force VOXL into Fastboot Mode. (any onboard button/ any other technic ) so I can flash it


  • Dev Team

    Hi @Gaurav-Borade ,

    There's the software way to reboot to fastboot (adb reboot bootloader) which requires an active adb connection, or the hardware approach which requires the debug add-on board....

    If you type fastboot devices or sudo fastboot devices does anything show up?



  • Hello,
    I am experiencing the same problem. Although, I do have the debug add-on board. I have been able to detect an adb and fastboot device a handful of times, but whenever I try a follow-up command I get an error and the device goes offline. Any suggestions?

    Note: I have tried powering the m500 from both a lipo & the standard 12V/3A wall outlet as suggested on this forum. I also have tried toggling the fastboot switch and running the install.sh program within 10 seconds of booting, but the device continues to go offline.

    No luck with restarting the adb server and reconnecting the device either.

    Screenshot from 2021-06-24 13-53-37.png

    Screenshot from 2021-06-24 12-37-46.png



  • When you go into fastboot, are you physically switching the fastboot switch back to normal? That switch needs to behave like a button (volume down on an Android phone). If the switch stays fastboot enabled, it will restart after 10 seconds



  • @Chad-Sweet I power on the device with fastboot switched on, then I switch fastboot off and leave it off.

    ... Although, if I leave fastboot enabled I don't notice the device restart after 10 seconds (LED stays lit and the fan continues spinning). Is that expected?



  • Update: I didn't realize how fast this operation needed to be done until reading this: "power on VOXL and then QUICKLY turn switch off and then hit ENTER to run the ./install.sh script" from this thread. After trying that a couple of times, it flashed, and appears to be functioning correctly now! 😃



  • @modaltb Thank you for helping

    I Tried it & Got following

    13dc3479-2fc3-439f-8f34-076c144200bc-image.png

    I don't have the hardware (debug add-on board) with me now, Will receive probably in next week


Log in to reply