ADB Device Offline



  • Hello,

    I recently encountered an issue with the VOXL drone when trying to connect to it over a USB connection using adb. Everything had been working just fine and then one day, I booted the drone up to begin working on it and it told me that it couldn't connect because the device was "offline". I've tried unplugging the drone and using a different USB cable but nothing has fixed this issue yet. Here is a photo of the issue I'm facing:

    bf42eb05-9157-4452-8731-42244e6e0ed4-image.png

    I've even tried to flash the system using the debug board, but get the same error that it can't because the device is "offline".

    0478ebfd-f42d-4a16-bc00-c68aff01835c-image.png

    I'm not really sure what to do at this point, any insight on how I might fix this issue would be great!

    Best,
    Jonathan Erikson



  • Hi @Jonathan-Erikson ,

    Seems like you are following the correct path, we've found that in some cases, we need to quickly turn the fastboot switch off after bootup.

    It's captured here towards the bottom: https://docs.modalai.com/unbrick-voxl/

    Note, you can ommit -f to try to preserve the data directory:

    3df47878-ac34-4aa2-8fe9-4ba2e5ae6c69-image.png

    Let us know how it goes, thanks!



  • I did attempt this as well and it still gives me the same error message that the device is "offline". After that, it gets stuck "Waiting for fastboot...", similar to the image above.


  • Dev Team

    Hi @Jonathan-Erikson ,

    OK, one last idea is power, how is this being powered? I've had some issues with low battery causing ADB issues as the VOXL can brown out if it's not getting enough current on bootup (inrush up to 6A).



  • @modaltb

    I took this idea and tried to boot the drone using a LiPo battery but am still having the same issue unfortunately. Originally, I was just using a standard 12V 3A wall plug, similar to the one available on the modalai website.


  • Dev Team

    Hi @Jonathan-Erikson ,

    OK let's get an RMA going. I just sent out a google form that we use to collect data (address, shopify number, etc.). Let us see what we can figure out on our end and not waste anymore of your time.

    Thanks!



  • This has happened to me before. I don't know what caused it but what fixed this for me was to run

    $adb kill-server 
    $adb start-server 
    $adb reconnect device
    

  • Dev Team

    @ryan_meagher Thanks for the feedback!


Log in to reply