Issue in Microhard paring with Slave unit

  • The m500 unit we received came with a microhard 2.4 GHz and we were trying to connect it with our Microhard unit that is configured as Slave unit with am IP address of And also we were trying to configure the VOXL unit with the following setup instruction in the link, but this instruction does not seems to connect with the slave unit we have. Is there any other parameter we need to change and how can we access the Microhard connected with m500 VOXL unit.

    The slave wireless is configured as shown below, so we were wondering if the frequency or the ID is not matching, which is causing not to pair. microhard.png
    Is there any way to access the Microhard in the voxl unit?

  • Dev Team

    @manzur If you followed all of the other configuration steps correctly there are a couple things to try.

    The first thing I would try is to increase the physical distance between the two modules, if you have both on a bench then there is often RF saturation if they are too close to each other. The other thing to try is to lower the "Tx Power" setting to it's lowest setting if you are indeed doing bench testing.

  • @tom Thanks for reply. I followed all the configuration steps and I have also tested by keeping the Microhard further, but the connection does not seems to work. I have also tried to use lowest TX power but same result. The only possible solution I see is to access the VOXL microhard unit and check all the configuration to match with slave unit, but I do not know how to access the Microhard using USB port or from the VOXL ssh terminal. Can you suggest ?

  • Dev Team

    @manzur The only way to do that without having the two connected would be to switch the Microhard modems, but I wouldn't recommend doing that if you don't have the correct tools.

    When you are on VOXL what do you see when you type ifconfig?

    Are you able to ping or ping from VOXL?

  • @tom I have already checked the ifconfig and it shows the the VOXL is connected with microhard

    and also I have tested master mode in microhard by holding the button for 10 sec. The IP ping test as follows:


    I have also tested the VOXL microhard unit by putting it in slave mode by pressing the button for 5 sec and it also shows in the ping result as follows:


    The problem is that, it does not connect with another microhard unit whether we keep that in master or slave. There must be some configuration issue that we must be missing and or it not matching with another unit. Can you please tell me what is the default Network ID: pDDL. For us the slave unit has pDDL. And the channel frequency is set as Channel-Frequency: 75_ 2476 MHz .

  • Dev Team

    @manzur pDDL is the default Network ID. Which Microhard modules are you using? 1800 MHz? 2400 MHz? It looks as though the VOXL side is fully functional.

    Are you able to take the standalone side Mircohard module and plug it into a PC in order to see if it correctly connects to the PC? That way you would be able to try pinging it to determine whether the IP address is being set correctly.

  • @tom We are using microhard from Airborne innovations 2400 MHz unit on the other side. And I can access the slave standalone unit perfectly with PC.

  • Dev Team

    @manzur From what I can see, it looks as though the Microhard carrier boards are doing their jobs as the correct network interfaces are appearing.

    Have you ever been able to establish a connection between these two Microhard modules in the past? It's possible that one or both are faulty.

    And just to confirm, on the standalone side you are using antennas as well correct?

  • @tom I have not been able to establish connection between these two Microhard modules. But independently the slave standalone unit has been used for another system as well and I know It is working. 0ad561d0-053a-45b7-96ef-fbd93611da3b-image.png
    Standalone unit

  • Dev Team

    @manzur I see, so the standalone isn't from us. Did you acquire the Microhard module that is in the add-on board from us? And is it also a pDDL2450?

  • @tom Microhard module that is in the add-on board from Modal AI as an add on to m500 unit and same is pDDL2450


  • Dev Team

    @manzur When both modules are powered on and you wait a couple minutes with no connection, what behavior are you seeing from the LED's on the VOXL add-on board?

  • @tom This is the image showing LED behaviour.


    From the bottom

    1. Lnk/ACT : OFF
    2. Lnk/100 : ON
    3. Lnk : ON
    4. CPU : ON
    5. RSSI_1, RSSI_2, RSSI_3 : blinking one after another
    6. RX : ON (continuous)
    7. TX : Blinking (low)

    Note: One thing I noticed now is that the Standalone microhard unit we have is 128 bit AES encryption model, where the Modal AI add-on module is showing 256 bit AES encryption model. Do you think this is the reason they are not communicating? All the microhard unit we have here is 128 bit AES model. If that is the case how can we access the Add-on Microhard unit?

  • Dev Team

    @manzur Interesting, that LED behavior indicates that the two modules are in fact connected. If the modules are searching for each other then the LEDs will cycle.

    As for the encryption question, I will look into it.

  • @tom Thanks for your reply. Let me know if you can come up with some solution. In the mean time I am trying to get a development board for the Microhard unit to plugin and see if I can log in to the config-webpage.

  • Dev Team

    @manzur Okay great, there is an option in the web interface under Wireless -> RF -> Encryption Type which should allow you to change the module's encryption type to 128-bit in order to match the other module.

  • @tom I was able to access the web interface by plugging the Add-on Microhard unit into a development board. And indeed I found the Network ID is mismatched and was set to as pMDDL instead of pDDL. Also the frequency was set to 76-2477 which is okay since I tried with multiple band with the slave unit as well. See the default configuration of the Add-on unit before changing


  • Dev Team

    @manzur Interesting, thank you for the information! Perhaps I was wrong about the default Network ID, I will take a note of that.

Log in to reply