Not going in Position mode



  • @tom said in Not going in Position mode:

    cat /etc/modalai/voxl-vision-px4.conf

    cat /etc/modalai/voxl-vision-px4.conf
    /**
     * VOXL Vision PX4 Configuration File
     *
     */
    {
    	"qgc_ip":	"192.168.100.174",
    	"en_localhost_mavlink_udp":	true,
    	"en_secondary_qgc":	false,
    	"secondary_qgc_ip":	"192.168.1.214",
    	"qgc_udp_port_number":	14550,
    	"localhost_udp_port_number":	14551,
    	"en_vio":	true,
    	"en_voa":	false,
    	"en_send_vio_to_qgc":	true,
    	"en_send_voa_to_qgc":	false,
    	"en_adsb":	true,
    	"adsb_uart_bus":	7,
    	"adsb_uart_baudrate":	57600,
    	"px4_uart_bus":	5,
    	"px4_uart_baudrate":	921600,
    	"offboard_mode":	"off",
    	"follow_tag_id":	0,
    	"en_apriltag_fixed_frame":	false,
    	"fixed_frame_filter_len":	5,
    	"en_transform_mavlink_pos_setpoints_from_fixed_frame":	true
    }
    


  • @tom @modaltb @Jeremy-Schmidt is there anything else I can send?



  • @gauravshukla914 see this post here. In there case they had the same symptom. To fix, they made sure voxl-imu-server and voxl-camera-server were running on boot and feeding the data to voxl-qvio-server



  • @Chad-Sweet I made sure this, but still no luck with the local position ned and its still failing to go into position mode. I have attached the screenshots.
    @modaltb @tom @Jeremy-Schmidt is there a way we can set up a screen share for this? I think it'd be great if we can do that and may be together we can come up with a solution for this.qgc.png voxl.png



  • Can you report what your EKF2_AID_MASK is set to in PX4 and post the value? thanks.



  • @Cliff-Wong its set to 280. I have also posted the PX4 param above somewhere in the beginning and you can have a look at that too.



  • Have you changed the firmware in some way? This is not normal behavior. You could try going to original firmware and settings: https://docs.modalai.com/flight-core-firmware/



  • @gauravshukla914
    thanks, if you are using standard firmware as Chad mentioned in the following post, PX4 (not voxl) selectively stops certain position updates in order to trigger specific logic in ECL. Saying that, the behavior you're seeing appears just like aid mask (280) is being ignored. If you watch this: https://drive.google.com/file/d/15MPZeez2zgfBQySNgxlsEqq3Ttj34b7M/view?usp=sharing I think I recreated your behavior as described (note "afla" = udp). Thus, you may want to explicitly set aid_mask/reboot to confirm the same behavior which will help us narrow down the problem to mavlink (possible crc issue) or px4-general logic.

    If you are using custom firmware, it very likely the aid mask param is not setting the internal modes properly.



  • @Chad-Sweet No I have not changed the firmware. The firmware version is 1.11.3. I have also attached the picture of it in my previous comments. We are running out of ideas now.

    @Cliff-Wong - Thanks for the video. We did set the aid mask explicitly to 280 multiple times and rebooted PX4, but still no luck


  • Dev Team

    Do you have a GPS/Mag plugged in? If not please try plugging in a GPS/Mag and set the PX4 parameter SYS_HAS_MAG to 1. There is a PX4 bug that prevents VIO-only operation if a magnetometer is missing, even if the magnetometer is not in use.

    We've been trying to get the bugfix approved and merged into PX4 master for over a year now but it seems to be a lost cause. For now our own branch of PX4 has the bugfix along with some custom tools for our ESCs. If your system starts working again with the magnetometer then we know somehow a standard PX4 image got onto your flight core instead of one of our own.

    Regards,
    James


Log in to reply