Seeker Drone Firmware Issue - Incorrect IMU Orientation?

  • Hello,

    I am working on a university research project where I recently inherited two seeker drones. One works flawlessly and can calibrate, fly forwards, and perform all other actions. The second one has some strange problems - for example, none of the many orientations available to 'calibrate' the sensors in PX4 match the true orientation of the seeker drone. I've run voxl-configure-extrinsics to configure the file /etc/modalai/extrinsics.conf and selected the 'seeker' preset option. However, this still does not work, and comparing the extrinsics.conf between the drones shows that they are NOT the same.

    Any ideas on how I can get the correct IMU orientation for the seeker drone? Up to this point, I've avoided messing with the /etc/modalai/extrinsics.conf file on the working seeker drone because I'm unfamiliar with the firmware and don't want to mess that one up too. Open to all ideas.

    Thank you,
    Nick B

  • Dev Team

    You should probably reinstall all of the software on the unit that isn't working. Maybe pull the calibration files off first that are stored in /data/

    Seeker uses APQ8096:

    If you wipe everything, worst case you need to recalibrate the stereo sensors after configuring for Seeker

  • @Chad-Sweet Hi Chad, thank you for your response! I have been attempting to flash new firmware but it appears that fastboot is not cooperating with WSL. Is there any way around using fastboot to install the firmware on the device? Or do you have any suggestions as to why this might be happening? ADB works completely fine and the device is recognized, but it is not recognized using 'fastboot devices'.


  • Dev Team

    We don't use Windows much, primarily Ubuntu. On Ubuntu though we need to run as sudo. Maybe you need to run as admin?

    Also, just from the command prompt

    fastboot devices

    should show a number if the board is in fastboot mode. You could set the switch and check manually if you can get into fastboot mode

  • @Chad-Sweet Thanks for the suggestion, I was able to flash the new firmware without a problem using Raspbian. After uploading, there were more preset options for 'extrinsics.conf' than before, and selecting the voxl1_seeker option worked this time. The vehicle is able to calibrate with the correct orientation. The firmware must've just been quite outdated.

  • @Nicolas-Ethan-Blanchard I also re-loaded PX4 parameters from the provided file in the GitLab, so that could have helped as well. Although, I do think that the IMU orientation parameter was set correctly initially, because it matched the parameter in the working drone.