VOXL ESC calibration + T-Motor F2203.5 3550KV



  • Hello,

    I'm using VOXL ESC Tools to calibrate VOXL 4-in-1 ESC v2 on a cutom-built airframe (~7") with T-Motor F2203.5 3550 KV and propellers 6" x 4". 3S and 4S batteries were used to power the ESC passed through a VOXL Power Module v3.

    without props being installed (no load), the motors spin normally in response to ``voxl-esc-calibrate.py"

    video
    Screenshot from 2022-11-18 14-23-40.png

    but with props, the motors spin abnormally and can not pass the initial phase. ``voxl-esc-calibrate.py" sends out 0 RPM as though the motors are not spinning.

    video2

    Screenshot from 2022-11-18 14-24-36.png

    • the idle amp of the ESC was measured at 0.46 Amp.
    • max power was limited on purpose here.

    Is there any consideration for the setup or recommendation on VOXL ESC Tools to calibrate other than using new motors with a lower Kv to get a higher torque?

    thanks


  • Dev Team

    Hi

    I can look into it. Can you please share the ESC params that you are trying to use while calibrating?



  • thanks for the replay.

    The ESC params I used for the results I shared above are
    Seeker_V1_tmotor_f2203_1500kv_Param_Rev_A.

    I also tried with esc_params_modalai_4_in_1_revb_1400KV_TMotor_MN1806
    and
    Starling_V1_emax1306B_2700kv_4030_3S_param_Rev_A
    and a few more which had a Kv coefficient more than 2000. But the results are the same as I have shared.

    That said, today I used
    esc_params_modalai_4_in_1_revb_holybro2216_880 which has Kv=800 and a 4S battery, and this setting worked for calibration. I tried with a 3S battery but it could not provide enough power. After ~%30 PWM commanded, the RPM drops (picture attached). I wonder if there are any of these ESC params which I can use with a 3S battery as well.
    PS.1. I tried with changing "vbat_nominal_mv" in the ESC params xml files but that did not work.
    PS.2. I have a VOXL Flight Deck on the drone.

    wierd.png


  • Dev Team

    Hi @mbahrami ,

    I just tested a similar motor Tmotor 2203.5 2850Kv with a 6 inch propeller at 12V power supply, using the Seeker V1 params and the motor starts and runs fine. I also tested other param files and every time it is able to start fine.

    Based on the behavior and observed RPM vs PWM result, i believe that either the Motor or the ESC is faulty. So I suggest the following:

    • test the same motor on another ESC channel (same ESC)
    • test a different motor of the same type on the same ESC, same ESC channel

    Note that due to 3-phase nature of the motor, it is possible for motor to spin with only two phases fully working and spinning without load is easier for a faulty motor / ESC.

    This will help figure out which one of the two (motor or ESC) is faulty. My guess would be that the ESC is the issue, but you will see.

    I hope this helps!



  • yes @Alex-Kushleyev, having done the test, it seems the ESC is faulty.

    I should have mentioned this before, but in my tests only the motor on the ESC's ID/channel 3 was working and the rest on the channels/IDs 0, 1, 2 were not work. so just used T-motor 2203.5 3550 Kv with the Seeker V1 params and the VOXL Wall Power Supply (12V) and switched the motors on different ESC IDs/channels. Again the new motor on the ESC id=3 was working and the others not. I also changed the motors and the same results using the Seeker V1 params.

    by the way the soldering did not seem to be an issue because I have checked them out by continuity tests.

    IMG_3615.jpg


  • Dev Team

    Please follow the steps here at https://www.modalai.com/pages/rma


Log in to reply