• The Wi-Fi was working fine out of the box and then when I attached it to my drone the Wi-Fi card is not being shown in ip a or ifconfig... I don't know what could have happened. Is there a command to enable the Wi-Fi adapter? My setup contains 4 motors 4 ESCs attached to a Power distribution board. The VOXL is powered via LiPo 3s 11.1v battery connected to the Power Module v3. I can ADB in but there is no WLAN0 in ifconfig. Please advise what I should do. I don't have a Debug Add-On board so I can't flash it to factory defaults.
    Print out of ifconfig:Screenshot from 2022-10-20 23-06-04.png

  • Dev Team

    @mirasul, that is weird.
    Let's start with your software version. What version are you running?
    What if you try

    voxl-wifi -f

    This'll reset wifi back to factory.

  • I have tried setting it back to factory, to my understanding it should broadcast as VOXL-<MAC ADDRESS of VOXL> however, it doesn't broadcast anything. Here is the output:
    Screenshot from 2022-10-22 18-15-04.png
    My software version:

  • I just replaced the wifi antennas but no luck still WLAN0 still not shown in ifconfig… please help me out. Do I need to RMA device?

  • Dev Team

    @mirasul This is most likely a hardware issue in which the WiFi chip on the VOXL has either failed or the solder connection between it and the board has failed.

    I would recommend sending it in for an RMA: https://www.modalai.com/pages/rma

Log in to reply