[INFO] Waiting for fastboot...



  • Hi there! I've been trying to flash my system image using Ubuntu 18.04 on VirtualBox and I am facing many difficulties.

    a29bdb1d-8a38-423a-ad4f-c6dd9087a0a6-image.png

    Current system image: ModalAI 3.3.0 (I want to upgrade it to 3.8.0+ so that I can update voxl-suite)
    ** the only package that allows that is voxl_platform_3.8.0-0.7 for VOXL 1

    voxl-suite: 0.5.0 (I have also done opkg update && opkg upgrade in VOXL, and it also has voxl-suite 0.2.0 now)

    I have [INFO] adb installed and [INFO] fastboot installed, but when I try sudo fastboot devices or fastboot devices, nothing happens, even though I can see the device using adb devices.

    I also do not have the USB Expander and Debug Board, but I do not think my VOXL needs to be unbricked since it loads up fine. However, when I run sudo ./install.sh, the board reboots and I have noticed that it browns out (the current draws only 0.05-0.06A). I am also using 8.5V of voltage. It may also not be a brown out because my current limit is capped, so I am not sure what the problem is.

    No matter how long I wait, or even after turning off the power supply and turning it on, I am always getting [INFO] Waiting for fastboot... If I do not reboot the device myself, I will not see it in Devices -> USB, but if I do reboot it, I will see the VOXL under USB.

    Any help would be much appreciated!


  • Dev Team

    @janikaoh I'm not sure if anyone here has tested using Ubuntu 18 in a VM, most of us run either Ubuntu 18, 20, or 22 natively on our machines. That would be the recommended route to take if possible as passing USB devices through VirtualBox can be iffy.



  • Using an Ubuntu device actually worked!!


  • Dev Team

    @janikaoh Great! We've seen VMs act unreliably with adb and fastboot so we always recommend that users run Ubuntu natively if possible.


Log in to reply