VOXL2 bricking itself randomly



  • Hi,

    I have had the VOXL2 brick multiple times on three different VOXL2 boards. 2 Stand alone VOXL2 boards powered using the LiPo battery (suggested for the Sentinel) and wall-connector and one VOXL2 board on the Sentinel. The VOXL2 fails to boot-up after running voxl-configure-docker-support. Once docker is running and I load my docker container in, I power off the drone and VOXL2 boards by disconnecting the XT60 plug. When I try to power it on again, by plugging it back in, the VOXL2 does not boot up on either the Sentinel and the stand alone boards. If I do lsusb I can see that there is a Qualcomm device connected to the system. But I am not able to adb shell into the VOXL nor can I SSH in. I seem to have to fastboot and reflash the system image for it to start working again and then I would have reconfigure everything again.

    This process has happened 3 times now after starting the docker daemon and downloading the necessary docker files when running voxl-configure-docker-support. I thought to myself maybe I have to do poweroff -f to safely turn off the VOXL2. I tried this and I ran into the same problem. But I shouldn't need to do this since when you turn off a drone, I usually been just unplugging the cable. Any advice and suggestions on this would be great!

    Thanks in advance,

    Rohit


  • Dev Team

    VOXL 2, like all embedded systems, get bricked when power is removed while flash is still open in the write state. It's likely configuring the docker setup is performing a lot of writes to the flash. poweroff should help, calling sync should help as well. As long as you make sure flash has flushed before pulling the plug, you should be fine

    You can see a writeup on the topic here, as it is common in all of this type of single board computers



  • I am unplugging the drone and VOXL2 boards after I exit/close the docker container and after the configuration process is complete. I then tried both typing in poweroff and unplugging the power. After both times, VOXL2 does not boot up properly.

    How does one check if flash has flushed?

    Thanks!



  • After reflashing the VOXL2 once again, I ran voxl-configure-docker-support, but I did not load any docker images. I setup docker daemon and docker-autorun. Then I followed your advice on using sync and poweroff. I entered sync waited a minute or two and then ran poweroff. Then I unplugged the VOXL2. I tried powering it on again and no adb devices are shown and I cannot adb shell in. It has bricked itself once again.

    Any other suggestions?



  • Any update on this?


  • Dev Team

    No, we will have to look at this in more detail internally. No ETA at this point.



  • Okay sounds good! Will be waiting for any suggestions!


  • Dev Team

    @rohitpillai Thanks for bringing this issue up.

    The voxl-configure-docker-support script is mainly for the VOXL1 platform and I believe is causing issues on 865 really required at this time for the VOXL2. Because the VOXL1 platform has a somewhat more custom built OS, it needed some tweaks....

    On VOXL2, we have Ubuntu 18 natively, and you can just install using apt: https://docs.docker.com/engine/install/ubuntu/

    We will address this in the next release, but in general for right now, you should be able to just install Docker following instructions above.

    To manually start docker images on bootup, you can refer to the older package as reference and this: https://docs.modalai.com/docker-on-voxl/#configuring-a-program-to-run-automatically-inside-a-docker-on-boot



  • Thanks! This has solved the problem.



  • @rohitpillai
    How did you unbrick voxl2?



  • @Nishkala I used this link - https://docs.modalai.com/voxl2-system-image/#force-voxl-2-into-fastboot

    You will need the latest platform release which can be found here - https://developer.modalai.com/asset/2


Log in to reply