Reject position control

  • We have flown the Seeker drone up to 4 hours maybe and everything with the VIO and position hold worked good. I did all the updates (v0.5.0) on the VOXL to get the voxl-mapper to work and it did work. In my thoughts it even worked with the VIO. Sometimes I did have Reject position control on QGC, but than I restarted the Seeker and I could fly in position mode again. But for some reason it keeps giving me the Reject position control, and now I am not able to fly in position mode anymore.

    I did quite some troubleshooting -> voxl-configure-excentrics/ camera/ QVIO/ PX4 etc. all of that I did do that make sure the VOXL was correctly set.
    I also checked if the FC got any Odometry data, but it did not get any of VOXL. At least I could not see the data with the mavlink inspector. It is weird, because I didn't change anything on the FC itself.

    We really need it go back up in the air for some more testing! Any idea???

  • Dev Team

  • Do you see output from qvio server using voxl-inspect-qvio? This usually happens when there is no localization data going to px4. You can also help debug this by enabling the send_vio_to_qgc flag in /etc/modalai/voxl-vision-px4.conf and see if you're seeing the odometry data there.

  • Thank you for the response! I didn't have time to look into this yet. But there is more going on with the system I think. WIFI also doesn't work anymore. And after trying to solve the WIFI, the ADB of the VOXL stopped working. So we for now we are using a different VOXL.

    Something else we are running against is the message Reject position control, with working VOXL CAM systems installed on our drones. When we fly everything is super! When we land, after the drone has bumped into things while flying (drone is collision proof) or when heavy wind was pushing it. We cannot take off after landing, it will display Reject position control. Only when the we connect a laptop to the QGC, we can hear that the VOXL reboots and then the Reject position control is gone, and we can go fly again. But if we use QGC via the PX4 Telemetry port, this doesn't happen, and we need to unplug and replug the battery to be able to get the Reject position control message away again.

    We don't really know why this happens and how we can solve this. It would of course be great if the VOXL didn't need to reboot in order the drone can fly again in position mode. But it already would be helpful that the VOXL would reboot without having to have WIFI connection with QGC. Please help!

Log in to reply