Connecting VOXL Microhard Modem with Skynav



  • Hi there,

    I'm trying to configure my VOXL's Microhard modem (1800 MHz) to connect to a Skynav tablet. This is my first time doing this and the instructions that I have are somewhat limited.

    My Skynav w/ QGroundControl has the following configuration:

    Local IP: 192.168.168.1
    Remote IP: 192.168.168.2
    Network Mask: 255.255.255.0
    Configuration User Name: admin
    Configuration PW: ****
    Encryption Key: ****
    Network ID: MH
    Channel frequency: 1825 MHz
    Channel Bandwidth: 8 MHz

    I've tried following (part) of the instructions here: https://docs.modalai.com/microhard-add-on-manual/ , which isn't entirely applicable, but followed them for the VOXL side.

    I wasn't able to get the two modems to connect and see each other. Any tips on where to begin? Sorry for the beginner-ish questions.

    Thanks!


  • Dev Team

    Hi @FourPointTwoMm

    From what I can tell from your message, it sounds like the Microhard modem on the tablet side is set up in "Master" mode and therefore is looking to pair with a modem in "Slave" mode.

    Do you have the Microhard modem on the VOXL side, set up in "Slave" mode?



  • Thanks Tom, that was my understanding as well.

    Which leads me to my next perhaps stupid question: how do I set up the Microhard modem with VOXL in Slave mode? 🙂

    The instructions on the page from the link above only explain how to set things up with the VOXL end as the Master.


  • Dev Team

    @FourPointTwoMm

    Press and hold the S2 button on the VOXL Microhard Add-on board for 5 seconds, then release. The module will then reset all settings to the default values required for a Slave module. This module will be assigned a default IP address of 192.168.168.2

    It is the same steps that we would usually use for the standalone board but instead just applied to the VOXL's add-on.



  • Ah, I see! That seems simple enough to try.

    Am I correct in my understanding then that 10 seconds = master, and 5 seconds = slave?


  • Dev Team

    Exactly. That is specified by Microhard, so if your Microhard modem on the tablet side has an exposed debug button then another option would be to set it as a "Slave" and it will connect to your VOXL's Microhard if it is still configured as a "Master".



  • Unfortunately, that didn't work. 😞

    I see lights flashing, and I think I was able to re-configure it to operate in Slave mode, but still no dice in connecting.

    I wonder if it's one of the other settings. Do you perhaps have any helpful tips as to where I can continue to explore different radio configurations? E.g., configuration files I can play with.

    I'm wondering if it has to do with a mismatch in one of the other settings (radio frequency, encryption, etc.)

    Thanks!


  • Dev Team

    Another setting to check is to make sure that both of the modems have a "Network ID" of "pMDDL". This should be default on the VOXL side but the two modems won't connect unless they have matching network IDs.

    You can also verify that the VOXL's modem is indeed in slave mode by checking to see if you can ping 192.168.168.2 from VOXL.



  • Thanks, I could ping 192.168.168.2 and confirmed that it was running in slave mode.

    I also tried a both pDDL and pMDDL as the network id on the Skynav end (previously it was set to a different value, so good call there).

    However, I still wasn't able to connect. I'm thinking it must be one of the other settings.

    I found in another thread: https://forum.modalai.com/topic/251/issue-in-microhard-paring-with-slave-unit/9, another poster also had some difficulty in pairing, but eventually troubleshooted using a web interface of some kind. I assume this is enabled by the development kit that Microhard sells?

    If I don't have this dev kit, is there some other way for me to configure those settings (e.g., channel/frequency, encryption, etc.). If you don't know I could also try to ask on the Microhard end for assistance.

    Thanks!


  • Dev Team

    @FourPointTwoMm Yes, the web interface is the easiest way to view all of the modem's settings. If you are able to ping the IP address of the modem, then all you have to do is navigate to the IP of that modem in a web browser and it should open to that interface. I had assumed that was what you were using on the tablet side to modify the settings.



  • Ok! I was able to get them to connect after playing around with the bandwidth/frequency radio settings. Going into the web UI did the trick, thanks!. I keep learning more and more. 🙂

    Working on another issue, which I'll just quickly tack on to this thread to avoid having to create a whole new one, even though it's unrelated to the original topic: I've got a hi-res MIPI camera that I'm able to use to stream video to QGroundControl over RTSP and voxl-streamer. For space reasons I'd like to connect this using two extension cables, though it seems that with two of them daisy-chained prevents the camera server from starting. Is this expected?


  • Dev Team

    @FourPointTwoMm correct, daisy chaining 2 will likely fail, this is what I've seen.... we've validated against the single extension only.


Log in to reply