Issue in Microhard paring with Slave unit



  • @tom I have not been able to establish connection between these two Microhard modules. But independently the slave standalone unit has been used for another system as well and I know It is working. 0ad561d0-053a-45b7-96ef-fbd93611da3b-image.png
    Standalone unit


  • Dev Team

    @manzur I see, so the standalone isn't from us. Did you acquire the Microhard module that is in the add-on board from us? And is it also a pDDL2450?



  • @tom Microhard module that is in the add-on board from Modal AI as an add on to m500 unit and same is pDDL2450

    2210729b-a92a-4a5f-813e-1445b856509a-image.png


  • Dev Team

    @manzur When both modules are powered on and you wait a couple minutes with no connection, what behavior are you seeing from the LED's on the VOXL add-on board?



  • @tom This is the image showing LED behaviour.

    ec27339a-bcd3-4a55-85ad-c39c6368b146-image.png

    From the bottom

    1. Lnk/ACT : OFF
    2. Lnk/100 : ON
    3. Lnk : ON
    4. CPU : ON
    5. RSSI_1, RSSI_2, RSSI_3 : blinking one after another
    6. RX : ON (continuous)
    7. TX : Blinking (low)

    Note: One thing I noticed now is that the Standalone microhard unit we have is 128 bit AES encryption model, where the Modal AI add-on module is showing 256 bit AES encryption model. Do you think this is the reason they are not communicating? All the microhard unit we have here is 128 bit AES model. If that is the case how can we access the Add-on Microhard unit?


  • Dev Team

    @manzur Interesting, that LED behavior indicates that the two modules are in fact connected. If the modules are searching for each other then the LEDs will cycle.

    As for the encryption question, I will look into it.



  • @tom Thanks for your reply. Let me know if you can come up with some solution. In the mean time I am trying to get a development board for the Microhard unit to plugin and see if I can log in to the config-webpage.


  • Dev Team

    @manzur Okay great, there is an option in the web interface under Wireless -> RF -> Encryption Type which should allow you to change the module's encryption type to 128-bit in order to match the other module.



  • @tom I was able to access the web interface by plugging the Add-on Microhard unit into a development board. And indeed I found the Network ID is mismatched and was set to as pMDDL instead of pDDL. Also the frequency was set to 76-2477 which is okay since I tried with multiple band with the slave unit as well. See the default configuration of the Add-on unit before changing

    5a6d73fb-a02b-4a5f-b74b-3f9e1e1619cd-image.png


  • Dev Team

    @manzur Interesting, thank you for the information! Perhaps I was wrong about the default Network ID, I will take a note of that.


Log in to reply