VOXL2 has two network interfaces for microhard modem



  • Hello,

    I am flashing some newly purchased VOXL2 development kits when I ran into this issue when using a microhard. When voxl-configure-modem is run, it creates two interfaces that connect to the microhard: eth0 and usb0. The IPs that are set on both interfaces are random, and are not consistent between reboots of the voxl2 board. Additionally, when both are active, any connections to QGC from the board through the microhard is greatly slowed down. I would like to permanently set the ip address of one of the interfaces to be something that I can control, like how voxl-configure-modem used to do, as well as permanently delete the other interface since it is not required.

    3466c3cd-719d-4d64-93a3-7d73e516fa28-image.png

    Things I have tried:
    Editing /etc/network/interfaces and removing an interface. This does not prevent both interfaces from reappearing upon reboot
    Screenshot 2023-01-11 at 2.59.48 PM.png

    ifconfig eth0 down. eth0 sets itself back to "up" automatically within a few minutes, even without reboot.
    ifconfig usb0 down. usb0 stays down when this command is run, but returns as up again upon the voxl2 board's reboot
    ip addr del dev eth0. It returns the error: Screenshot 2023-01-11 at 3.02.25 PM.png
    sudo iw dev eth0 del. It returns the error e788843f-0662-4837-9b4d-14256f892d45-image.png

    Here is what VOXL2 Version I'm running:
    Screenshot 2023-01-11 at 2.52.09 PM.png

    I did already try running apt-get update && apt-get upgrade


  • Dev Team

    This post is deleted!

  • Dev Team

    You must be using an older version of the Microhard add-on that had the LAN7500 Ethernet to USB chip installed.

    It seems you could check if eth0 was there and run ifconfig usb0 down in a startup service if eth0 is present?



  • @Chad-Sweet I think that would work. Do you know if the same type of Microhard add-on would have exhibit the same symptoms with a VOXL1?


  • Dev Team

    No, I do not know. VOXL 2 is a much newer kernel and OS and it may not behave identically



  • @Chad-Sweet Got it, thanks!



  • General QOL update: I automated a script using cron to ifconfig usb0 down and change the eth0 ip address to what I wanted using ifconfig eth0 <ip>. This only works if the script is run using sudo


Log in to reply