Voxl cam to qgc



  • Hello,
    I would like to stream video from voxl cam to qgc using voxl streamer.I followed the steps but the video is not visible in qgc.I have voxl-camera-server running and voxl-streamer running, and I have also added the rtsp url in qgc video settings,am I missing something? please help


  • Dev Team

    @keil It would be helpful to get some debug output from voxl to help diagnose the issue. Can you send the output of voxl-inspect-services? There is a debug command line option for voxl-streamer. It would be helpful to get the output from that as well. The flag is -d. You'll want to start voxl-streamer from the command line using whatever options you normally use plus the -d option. Make sure that voxl-streamer is not already running when you do this. If it has been auto started with a systemd service then you can stop it with systemctl stop voxl-streamer. And I'm guessing that you already looked through the voxl-streamer documentation at https://docs.modalai.com/voxl-streamer/?



  • this is the output when I run voxl-streamer -d

    Enabling debug messages
    Using configuration file /etc/modalai/voxl-streamer.conf
    MPA interface chosen
    Input pipe name /run/mpa/tracking/
    Output stream width 640
    Output stream height 480
    Output stream bitrate 1000000
    Output stream rotation 0
    Output frame decimator 2
    No image overlay specified
    

    when I run voxl-inspect-services

    docker-autorun       | Disabled  | Not Running | Not Running
     docker-daemon        | Disabled  | Not Running | Not Running
     modallink-relink     | Disabled  | Not Running | Not Running
     voxl-camera-server   |  Enabled  | Not Running | Not Running
     voxl-mavlink-server  | Disabled  | Not Running | Not Running
     voxl-modem           | Disabled  | Not Running | Not Running
     voxl-portal          |  Enabled  | Not Running | Not Running
     voxl-qvio-server     |  Enabled  |   Running   |     0.0
     voxl-streamer        | Disabled  | Not Running | Not Running
     voxl-time-sync       | Disabled  | Not Running | Not Running
     voxl-vision-px4      |  Enabled  |   Running   |     4.0
     voxl-wait-for-fs     |  Enabled  |  Completed  |  Completed 
    
    

  • Dev Team

    @keil said in Voxl cam to qgc:

    voxl-camera-server | Enabled | Not Running | Not Running

    Hi,

    It looks like the camera server has encountered an error when trying to start since it's enabled but not running, this is usually due to either a misconfiguration or a hardware issue. Can you show what journalctl -u voxl-camera-server and cat /etc/modalai/voxl-camera-server.conf look like. These are the camera server logs and config file respectively.


Log in to reply