cannot connect usb camera over USB - C adb port

  • I want to connect a usb 3.0 camera to the usb c port. After connecting, I am unable to see my device when I do lsusb. The camera powers up. I can login using the adb shell. So the usb c is working. I am not sure what settings need to be done to get my usb camera working with usb c.

  • Dev Team

    @Jagatpreet-Singh-Nir What camera are you trying to use? Some cameras have a large power requirement that cannot be satisfied by the port (i.e. the cameras are not USB spec compliant).

  • I am using Flir Boson 640. The camera powers up however it is not detected as a device when I do lsusb.

    We tried running the camera on the usb port used for wifi dongle. It works fine there.

    We also tried to run an IMU on usb c port which has a much lesser power requirement ( 5V @ 200 mA). It did not run.

  • Dev Team

    @Jagatpreet-Singh-Nir I don't think any of us have tried attaching peripherals to the USB C port. We'll have to take a look and see what is going on. Do you see any messages in dmesg when you attach the camera?

  • Here are dmesg logs in the google drive link:
    There are two files; one when the usb device is plugged in to voxl 2 usb c port and then the second one when the same device is unplugged.

  • Dev Team

    Thanks for the logs @Jagatpreet-Singh-Nir , we'll need to dig into this. It seems like it's not being detected, we attempted a different device an believe to have replicated what you're seeing. We'll reach out with updates as we have them. Thanks!

  • @modaltb @Jagatpreet-Singh-Nir

    I have a similar issue when trying to connect a USB2/3 camera over the adb port, which was the way I've previously gotten the Voxl1 to run a FLIR Boson camera. The /dev port doesn't show the usual videox port, and lsusb also doesn't show the usb connection, but the camera led light does turn on.

    This is also different from the rb5, where I've managed to run two separate USB cameras through the adb port, which I thought would transition smoothly over to the Voxl2. Are there additional steps we need to take to use the adb port as a serial connection for USB cameras, like add dialout group or anything like that?

  • Dev Team

    @sarahl thanks for the information this helps us actually.

    I’ll check out the differences between the two kernels on RB5 and VOXL2 in this area and see what I can find.

    In efforts to speed up boot ups, I did yank out DT nodes so hopefully I messed something up that I can find.

    I don’t know of a way to make the usb/adb port into serial. Using normal usb port with Ftdi yes. If we get this port to be used as host then likely it will fall into place.

  • What is the recommended configuration to run the FLIR Boson then, since it is listed in the feature matrix of the VOXL2?

    I am having the same issue as @Jagatpreet-Singh-Nir on the USB C with the Boson 640. It seems that I can get the camera recognized on the USB-A port of the VOXL USB Expansion Board, but then I can't use this port for the wifi dongle any more. USB hubs don't seem to work to split this USB-A port between the dongle and the camera.

  • Hi all,

    I am also interested in connected FLIR Boson to VOXL2 - is it recommended to use the JST USB3.0 port on the 5G expansion board or the USBC/adb port.

    Also if it is the JST port - are there any recommended breakout cables to purchase?

    Lastly, do you know if the supported FLI Boson mentioned in the specifications matrix is the 320 or 640 - and if it was tested with USB 2.0

  • Dev Team

    Hey all on thread, some updates here.

    Main issue - USB-C as host not working yet on VOXL2:

    • This is my next top priority defect to resolve. I've put a couple days towards it but haven't cracked it yet, but am looking back shortly.

    Recommended configuration for Boson connection:

    • If you also need two USB ports, then this board (the M0090 carrier board only) which has:

      • a 4 pin JST connector, USB2.0, possible cable is to use is MCBL-00009 or you can make one pretty easily
      • 10 pin JST connector, USB3.0, we are posting a new MCBL-00022 soon which is a 10 pin JST to USB3 (within a week likely) or you can make your own
    • if just 1 USB port, then we have a smaller M0078 USB debug board

    • if just 1 USB port AND you want to add an applications processor UART port on 4pin JST, we will have a new M0125 up online shortly, which I think is pretty cool!

    Using out of the USBC connector will prevent you from adb access.... so in a vehicle if it's permanently mounted there (and assuming I get the fix!) then you could prevent ability to flash it later on if needed or to troubleshoot, but if that's no issue then I'll update you ASAP when I have updates on this.

    Which Boson?

  • Thanks @modaltb . Do you know if the MCBL-00022 cable is still planned to be released this week?

  • @modaltb Did you ever have any luck resolving the USB-C host issue for the VOXL2? Has an update been released that includes this fix?

  • Dev Team

    Hi @wijone we have not unfortunately. It's still an open item to resolve, but as there's a work around using above, we've not put a resource on this particular issue at this time.

  • Hi,

    I'm interested in connecting the lightwarelidar sensor(SF45/B) to VOXL2 using USB C too.
    I tried two settings to connect to the VOXL2 of the Sentinel drone.

    • LiDAR - (Micro-USB 3.0) - USB hub(USB C) - VOXL2
    • LiDAR - (Micro-USB 3.0) - USB hub(USB C)

    After connecting, I did the lsusb command, but couldn't see the device.
    If connecting to a microhard modem using a 4-pin connector is the right way to use a LiDAR sensor, I wonder what port names are available in the /dev directory.
    If not, is there a recommended configuration for the LiDAR connection to VOXL2?

    Thank you

  • I was looking this up the other day and stumbled across this forum thread. I have a high frame rate (90fps+) camera from Allied Vision that works across the USB 3.0 bus, but using the USB-C port would be much easier for integration. Just checking in to see if there had been any progress on using this port for high data rate cameras, etc. Thanks!

  • Dev Team

    HI @jdott ,

    At this time, no we don't have a SW solution to get the USBC port as a host.... so the USB3 approach warrants an add-on board like this on

Log in to reply