voxl-tflite-server master build not working on apq8096



  • @Matt Turi
    Hi,
    i've encountered an issue with the new master branch when building from source. When architecture is set to arm64 it won't install on apq8096 due to:

    Not selecting voxl-tflite-server 0.2.0 due to incompatible architecture.
    

    had to change that back to in voxl-tflite-server/pkg/control line 5:

    Architecture: all
    

    then it worked. just wanted to let you know.


  • Dev Team

    Glad to hear someone's building our packages themselves!

    Yes, we're most of the way through migrating to a more platform independent build system that will let us use these packages on the qrb5165 platform as well. This is one of the things we've had to change, the next voxl system image will have a tweak allowing these packages, but if you want to install them in the meantime, you can manually add the tweak by adding the line arch arm64 7 to /etc/opkg/arch.conf on your voxl and running opkg update


Log in to reply