voxel-portal shared libraries error



  • Hi.

    I've been trying to calibrate my tracking camera with the voxel-calibration-camera in
    3.3 voxl version.

    The problem is i cannot see the front view of the camera, or any interface.

    I noticed there is voxl-portal , however when i try to run adb shell voxl-portal i receive the following message:

    voxl-portal: error while loading shared libraries: libmongoose.so: cannot open shared object file: No such file or directory

    I tried to create a voxl-portal pkg manually but there are missing third party repos such as mongoose and jpeg-turbo, and I am having difficulties trying to merge them or even build them according to the voxel gitlab (the mongoose holds jpeg-turbo README, and i also couldn't found submodules in the voxel-portal as mentioned ).

    any help?

    if there is a way to push in the libmongoose.so, I would like to know how to do it,
    but if there is a global solution, I would prefer that.

    Thanks in advance


  • Dev Team

    Can you update the entire voxl-suite? It is going to be difficult to pick and choose different versions of software. The latest voxl-suite will have all the tools you need


  • Dev Team

    This is an issue we are aware of and is due to the renaming of all packages using an underscore(replaced with a dash). To properly install packages that depend on the updated names, you can run this command to remove all affected packages with the added --force-depends flag:

     opkg remove libmodal_json libmodal_pipe libvoxl_cutils libjpeg_turbo --force-depends
    

    This should forcefully remove all these packages, and if you attempt to install voxl-portal again after running this, it will install the latest dependencies without conflict.

    The same command will fix any updated packages complaining about  "check_data_file_clashes:" with regards to one of the packages in the remove command above, and only needs to be done once.



  • Thanks for the answer, I found another solution as well that worked for me.

    It is probably more intuitive for experts, but i noticed that in the third party from your git you should also imply git submodule init and git submodule update .

    After doing that, the old instructions worked semi-properly, and I could reinstall the voxl-portal package with not farther problems. It's just the README files that were not so obvious in explaining so.


Log in to reply