OPKG failing



  • Hello,
    I ran "opkg update" then "opkg upgrade" which made me run into a dependency issue
    "Not selecting librc_math 1.1.2 as installing it would break existing dependencies.
    Not selecting opencv 4.5.1 as installing it would break existing dependencies.
    Not selecting libmodal_pipe 1.2.2 as installing it would break existing dependencies."
    Additionally I tried " opkg install voxl-camera-calibration" and got "Not selecting opencv 4.5.1 as installing it would break existing dependencies."

    How do I resolve these dependency issues to get the camera calibration feature?

    Thanks!


  • Dev Team

    Hi,

    Despite how dire these look, they're actually warnings, not errors. The older versions of these packages were built for a specified architecture, as opposed to our new builds that are architecture independent, but OPKG treats them differently and throws the very aggressive warnings despite nothing actually being wrong. If you ran opkg install voxl-camera-calibration, it should successfully install, even if it shows those warnings. You can check this by running voxl-calibrate-camera --help to validate that it did install properly.



  • Thanks for the quick reply!
    The only issue is
    10c99f9a-7437-4e0d-8246-40f6dc54f9d0-image.png

    but also:
    f4ab8a80-7bf7-48c5-ab01-323e3ee71bf8-image.png

    I tried rebooting as well. How do I resolve this?


  • Dev Team

    the command line executable is voxl-calibrate-camera not voxl-camera-calibration, it looks like it's installed and up to date and should work with voxl-calibrate-camera --help



  • 🤦
    Thank you so much!


Log in to reply