ADB not connecting



  • Using ADB I can't connect to the VOXL. adb devices does not list the voxl devices and adb wait-for-device times out. I was using ssh to connect to the VOXL over a radio network, but now that the network is interrupted I can't reconnect using ADB.


  • Dev Team

    Hi @jacksparkman ,

    Were you previously able to connect over ADB? E.g. was it working and then stopped or did it never work? Trying to trouble shoot a few hardware related items first (e.g. USB cable, laptop).

    Thanks!
    Travis



  • Hi. I was able to ssh back into the VOXL.
    I am now having trouble connecting to the internet on the VOXL.
    This is the output of network configurations
    yocto:~# ifconfig
    eth0 Link encap:Ethernet HWaddr 0E:25:77:5E:34:29
    inet addr:192.168.168.100 Bcast:0.0.0.0 Mask:255.255.255.0
    inet6 addr: fe80::c25:77ff:fe5e:3429/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:606 errors:0 dropped:0 overruns:0 frame:0
    TX packets:984 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:51773 (50.5 KiB) TX bytes:79772 (77.9 KiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:55100 errors:0 dropped:0 overruns:0 frame:0
    TX packets:55100 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:4286473 (4.0 MiB) TX bytes:4286473 (4.0 MiB)

    wlan0 Link encap:Ethernet HWaddr D8:0F:99:55:94:97
    inet addr:192.168.1.6 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::da0f:99ff:fe55:9497/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:1130 errors:0 dropped:53 overruns:0 frame:0
    TX packets:164 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3000
    RX bytes:198391 (193.7 KiB) TX bytes:13088 (12.7 KiB)

    yocto:~# ping google.com
    PING google.com (172.217.15.110) 56(84) bytes of data.
    ^C
    --- google.com ping statistics ---
    6 packets transmitted, 0 received, 100% packet loss, time 5003ms

    yocto:~# ping 172.217.15.110
    PING 172.217.15.110 (172.217.15.110) 56(84) bytes of data.
    ^C
    --- 172.217.15.110 ping statistics ---
    3 packets transmitted, 0 received, 100% packet loss, time 2003ms


  • Dev Team

    Hi @jacksparkman ,

    It looks as though you are running a Microhard connection. This may be interfering with your VOXL's ability to connect to the internet. You can disable the Microhard connection on startup by using systemctl disable voxl-modem and rebooting your VOXL. When you are ready to re-enable your Microhard connection you can use systemctl enable voxl-modem.

    This may solve your issue. If not, are you using your VOXL's Wi-Fi in station mode and ssh'ing through your local network or in Soft AP mode and ssh'ing directly into VOXL?

    You will need to have your VOXL in Station mode in order to SSH in as well as connect to the internet.

    Thanks!
    Tom



  • That worked! Thanks


Log in to reply