mavros node on base station fcu_url



  • Hi,
    I usually connect my QGroundControl (running on base station) to the voxl which in my unsderstanding "routes" the mavlink data from the flight core to my base station.

    Sometimes I want to run a mavros instance not on the voxl but on my base station. I am not sure how to configure this node correctly in order to connect to the flight core using voxl as "wifi link". It works if I set the fcu_url param like that: udp://:14550:@VOXL_IP:14556 but then the link in my QGroundControl fails. I guess it is because both connections are running over port 14550. I have no idea how to set fcu_url and gcs_url`. Or do I have to install additional software on the voxl to route the packages?

    Any help would be appreciated!



  • Hi Rapit, have you looked at this doc here?

    I think you'll want to look at this parameter "en_secondary_qgc"



  • Hi Chad,
    thank you for the link. I did read section before but I could't see how it would help me as the port on the outgoing connection is still the same.

    I just configured my base station ip in ggc_ip and secondary_qgc_ip (and en_secondary_qgc) and the connection to my ground control station is successfully initiated by voxl. But when I fire up mavros at my ground station, QGroundControl again loses the connection to voxl, so initiating "from the other direction" does not seem to solve the port conflict.



  • Hi Rapit,

    You don't need the secondary qgc_ip, just one udp link from VOXL to MAVROS. In this case you would use MAVROS as another link in the chain between VOXL and QGC.

    VOXL <--> MAVROS <--> QGC

    Try launching mavros with the fcu_url :
    fcu_url:=udp://VOXL_IP:14550@:14550

    and gcs_url:
    gcs_url:=udp://@127.0.0.1

    You may need to change the port to QGC to something else (like 14551) to avoid a conflict.

    Best,
    James



  • Thank you, it works now. I did not think about using my local mavros as connection link between voxl and QGroundControl.

    I changed the port. The original issue was a binary installed mavros which crashed when using a gcs_url. So I thought it was a configuration problem but building mavros from source and running with your proposed configuration worked. Thank you again!

    Raphael


Log in to reply