Parameter Checksum Invalid (ESC)



  • Hi,

    I'm working with the Qualcomm Flight Pro and VOXL ESC v2. In order to check the motor mapping layout, I connected the ESC to the 'Qualcomm ESC Interface' via a USB to Serial Converter. The interface can auto-connect to the ESC successfully and I can indeed connect and spin all four motors. But the rpm reading was way off from expected (reached above 35k). In order to solve this, I tried the 'Load from ESC' under the 'Parameters' tab.

    It gave me the following error: Parameter Checksum Invalid.
    Screenshot from 2021-06-29 20-09-35.png

    I'm not sure if this is an ESC or the Qualcomm interface issue.
    Any tips on this issue would be greatly appreciated. Thank you.

    Regards,
    Adarsh


  • Dev Team

    Hello Adarsh,

    Please make sure to use the latest software for ESC testing from https://gitlab.com/voxl-public/flight-core-px4/voxl-esc (master branch). Using voxl-esc-scan.py, please detect the board and let me know which hardware version (it will be ESC V2 rev A or rev B, I believe you have rev A). There is another script voxl-esc-verify-params.py which has ability to download params from each ESC and compare it against existing params (in params folder). I believe that once you download the params, they should be either the same as or very close to esc_params_modalai_4_in_1_reva.xml.

    We are currently not supporting the old Qualcomm ESC GUI and just providing command-line python tools (Although I believe the GUI should still work, as long as you get it as part of the voxl-esc install - it is part of the binary package you need to install from modalai downloads). Params are in XML format and should be easy to work with. Can you confirm where you found the GUI, I just want to make sure folks are looking in the right location..

    ESC V2 revA and revB has very minor differences in the hardware itself. You can compare two param files esc_params_modalai_4_in_1_reva.xml and esc_params_modalai_4_in_1_revb.xml which are just default params you can use for a small motor. The only thing that should be different is the current sensor sensitivity (as far as params go)

    Please find additional information here: https://docs.modalai.com/voxl-esc-v2-manual/

    Alex



  • Hi Alex,
    Thank you for your reply. The hardware version of my ESC is rev B.
    Screenshot from 2021-07-19 13-10-47.png

    I tried running the 'voxl-esc-verify-params.py'. It kinda shows the same error as the GUI.
    Screenshot from 2021-07-19 13-26-01.png
    I'm not sure what this means. Could you help me with this?

    Best,
    Adarsh


  • Dev Team

    Ok this means the firmware and corresponding params are old. Let me double check when we sent the boards to you and see what params it had. The solution is to update the firmware to latest, which is easy to do. If you have not changed the params from original, then you dont need to worry about porting old params to new (there were a few minor changes). I will share the latest firmware today.


  • Dev Team

    Hi Adarsh,

    Software version 34 is the latest, so you should be OK. It looks like you are using some old software tools. Can you please get a clean check out of voxl-esc (master) repo and follow instructions to obtain voxl-esc-tools-bin : https://gitlab.com/voxl-public/flight-core-px4/voxl-esc/-/tree/master/tools (see readme). You probably have some old code from when we released it from Qualcomm and the parameter struct has changed since then.

    Alex


Log in to reply