Flight Deck USB not connecting to QGroundControl

  • I am currently trying to set up our VOXL Flight Deck and I cannot seem to get the flight deck to be recognized by QGroundControl to update the firmware and upload all the parameters. I have tried multiple USB cables and am sure that the USB is connected to the right place. I believe that there is some sort of connection going on because the flight deck will flash green for five seconds so it knows that it is connected via USB but it just won't connect to QGroundControl. Is there some intermediate step that I am missing so that it will interface?

  • Dev Team

    @DillonAllen If you haven't yet, I would recommend checking out this page of our docs: https://docs.modalai.com/voxl-flight-deck-getting-started/

  • @tom I have been using that, but trying most things in that guide has not provided any results except for anything with ADB. From what I've seen in the quickstart it doesn't seem like using ADB is necessary for at least the firmware and basic controls, or am I wrong and that it necessary?

  • Dev Team

    @DillonAllen That's correct, if you are just connecting to QGC via USB to the flight core portion of the board then you don't have to worry about ADB.

    Can you share an image of your setup?

  • @tom Setup This is the current setup with the USB Running to QGroundControl

  • @tom Also as a side note I am able to connect to QGroundControl via wifi.

  • Dev Team

    @DillonAllen ,

    The VOXL Flight has the Flight Core 'sub circuit' on-board, and when that side powers up and detects USB, the LED at the pointy tip of the board would flash green quickly for a few seconds indicating it's in bootloader mode.

    This is a quick check to see if the microcontroller running PX4 is detecting USB or not.

    Also, I'm assuming you have not modified the Flight Core FW or parameters. If you have, please let us know and we can explore this area.


  • @modaltb The LED Will flash for a few seconds when the USB is attached and not flash when there is no USB connected so I'm assuming that the board is detecting some sort of connection. Also, we have done nothing else to modify the board or parameter since we have done nothing with the ADB and have not been able to even connect via USB at all unless inserting our blank SD card did something which I doubt.

  • Dev Team

    @DillonAllen Sorry I just saw that you posted that above and I missed it.... OK let me think of some options here, if needed I'll email you and we can connect for a screen share.

  • @modaltb Okay, that sounds good thank you!

  • Dev Team


    The only thing on the line there are diodes (D59, D60)... otherwise it's a straight connection into the microcontroller.

    You could visually inspect D59 and D60, although it's under the board (look fur the U7 silkscreen).


  • @modaltb I visually inspected the board and didn't see anything wrong with any components. I wasn't able to locate U7 on the flight deck board, but I was able to find it on our separate flight core.

  • Dev Team

    OK. One last thing and then I'd have to think we may need an RMA to check it out... If the cables and host machine running QGC functions on other Flight Cores, than the remaining item is that connector/connection to the microcontroller...

    We can try to see a status of the MAVLink connection on the USB port by connecting over WiFi.

    Get the connection up to QGC, and then go to the MAVLink terminal and run mavlink status command (I think that's what it's called, I don't have HW up right now to verify) and check for the connection on /dev/ttyACM0 (this is auto started here)

  • @modaltb Sorry for the late reply I got caught up in something, but we ended up managing to get it to connect via usb, but now my next question is that now do we just set up the flight deck just following the VOXL guide then the Flight Core guide?

  • Dev Team

    The VOXL Flight Deck should come mainly pre-configured (we calibrate cameras on that assembly, so we configure the computer vision features (VIO by default) to startup out of the box, and Flight Core's internal TELEM port is pre-configured, so you should have a MAVLink connection between the VOXL 'side' and FlightCore 'side'.

    You have QGC over WiFi which means you've got voxl-vision-px4 up, so you are good.

    Are you using the computer vision features? Most of that is configured through this: https://docs.modalai.com/voxl-vision-px4/

    You'll want to update the PX4 params for your particular vehicle, and do the calibration and tuning as normal (I'm not a skilled pilot so that's out of my realm), but the basic setup is captured roughly starts here: https://docs.modalai.com/flight-core-connections/

    If you are stuck on particular items feel free to keep 'em coming.

  • @modaltb Now that I am retrying to connect via wifi the VOXL will no longer show up on my list of possible internet connections, I've even checked the two connections on the bottom of the board.

  • Dev Team

    @DillonAllen Are you able to connect via. ADB?

  • @tom We have not tried ADB, but we managed to get it connected via a SIK radio. We have calibrated everything and installed the parameters package and now we are just assuming that once collision detection is enabled the drone will be good, the only thing is that I am unable to find the Odometry in the MAVlink inspector. When I run the listener vehicle_visual_odometry command it just returns "Never Published" so I'm concerned I'm not getting VIO Data.

  • Dev Team

    @DillonAllen Without WiFi, the only way you'll be able to debug VOXL related things is via. ADB so I would follow this guide: https://docs.modalai.com/setup-adb/ in order to setup ADB on your host computer.

  • This post is deleted!

Log in to reply