Resurrecting this modem issue as I have an identical problem



  • Re: LTE - Modem Works But Cannot Ping

    Identical and followed all the steps/suggestions in this thread. The modem works, the registration is made, the IP is leased, and the big kicker is I even have DNS through the connection! I can ping any website by name and see the DNS resolve it to an IP, but no response to a ping from anyone anywhere. Not even my own active gateway IP as shown by Route -n. wlan0 is down for all testing including disabling voxl-modem then restarting it with the shell script. The SIM is ATT prepaid phone and works in both of my phones (I tried both SIMs) I've tried the APN the phones are using (nxtgenphone), phone, and broadband. My only other thought is that ATT phones after last year have to be VoLTE capable since they did away with their 3g network (or so they say..) and I have no idea if that affects this modem in a negative way..


  • Dev Team

    @Bulldog357 That IP that you're getting on wwan0 is not a public IP and therefore can not be pinged directly. If you want to connect to your device remotely you'll have to either use a VPN or request a static IP from your carrier.

    See a little infographic here: https://docs.modalai.com/sentinel-user-guide-connect-gcs/#connecting-to-qgc-over-5g

    If you want to get a VPN service up and going quickly, I've recently been recommending https://tailscale.com/ as they have a solid free tier.



  • @tom Tom, Thanks for the Saturday reply! I' know I won't be able to ping the device's IP from the internet, just like I can't ping my phone or any other cellular device. They're inside the carrier's NAT'd subnet. I get that. But I cannot ping any public ip FROM the device. At the end of that old thread, he shows the Voxl pinging 8.8.8.8 and getting a response. I still don't, after following all of the suggestions in that thread. Like I said, I can get a DNS response if I ping a hostname, just no response to the ICMP from the host. Things that might help me: Another SIM from a different carrier or (or carrier's reseller, as most of the IoT SIM providers tout using ATT, T-Mobile and Verizon's networks, but have their own APN's..) to try. I'm working on that. In the meantime, coming from my early beginnings jockeying Hayes modems from DOS 3.3 running a BBS (Bulletin Board System, the pre-internet way we communicated..) I'm familiar with the Hayes AT command set (or used to be..) so I'd like a document (that I can't find on the Sierra site) listing my modem's AT command set so I can dig deeper into this problem myself. The Tailscale VPN looks nice and may be the simplest route (at a cost, and once I can actually talk to the outside world with this thing..) but I'm linking to a good video for you guys to look at. This guy is pretty savvy, and what he's doing here works. Without a VPN I might add.. The reverse SSH tunnel is quite interesting. Worth a look.
    https://www.youtube.com/watch?v=IokyotAGbJI


Log in to reply