ESC Calibration issues


  • Dev Team

    Hi @Riley-Dove ,

    Sorry, something is happening when editing maybe... This setup is heavily used all over so trying to see what up, we can do a screen share if the following fails.

    What if you do the following, without editing the file at all.

    • systemctl stop voxl-vision-px4
    • voxl-configure-vision-px4 -f
    • cat /etc/modalai/voxl-vision-px4.conf

    Can you then copy paste the output of the last command here?

    Then if the JSON output looks OK above, try to start again... systemctl start voxl-vision-px4.

    This is where I'm getting the file.



  • Looks like that worked.

    ~ # systemctl stop voxl-vision-px4
    ~ # voxl-configure-vision-px4 -f
    loading and updating config file with voxl-vision-px4 -c
    Error parsing config file before:
    /usr/bin/voxl-configure-vision-px4: line 120: 3072 Segmentation fault voxl-vision-px4 -c
    ^ don't worry about the segfault ^

    attempting to use camera configuration 3
    adding override_cam_id value=1 to /etc/snav/camera.downward.xml
    adding override_cam_id value=2 to /etc/snav/camera.stereo.xml
    reloading systemd services
    disabling all the snav services
    starting imu_app
    Created symlink from /etc/systemd/system/multi-user.target.wants/imu_app.service to /etc/systemd/system/imu_app.service.
    WARNING: Missing stereo calibration file. Follow instructions here to
    calibrate if you wish to use stereo visual obstacle avoidance.
    https://docs.modalai.com/docs/quickstarts/calibrate-cameras/

    DONE configuring ModalAI Vision Lib
    enabling voxl-vision-px4 systemd service
    Created symlink from /etc/systemd/system/multi-user.target.wants/voxl-vision-px4.service to /etc/systemd/system/voxl-vision-px4.service.
    starting voxl-vision-px4 systemd service
    DONE configuring voxl-vision-px4
    ~ # cat /etc/modalai/voxl-vision-px4.conf
    {
    "qgc_ip": "192.168.8.60",
    "en_localhost_mavlink_udp": true,
    "en_secondary_qgc": false,
    "secondary_qgc_ip": "192.168.1.214",
    "offboard_mode": "figure_eight",
    "en_vio": true,
    "en_voa": false,
    "en_send_vio_to_qgc": false,
    "en_send_voa_to_qgc": false,
    "en_adsb": false,
    "adsb_uart_bus": 7,
    "adsb_uart_baudrate": 57600,
    "px4_uart_bus": 5,
    "px4_uart_baudrate": 921600,
    "R_imu_to_body": [[0, 1, 0], [1, 0, 0], [0, 0, -1]],
    "T_imu_wrt_body": [0.068, -0.015, -0.008],
    "height_body_above_ground_m": 0.05,
    "T_stereo_wrt_body": [0.10, -0.04, 0.0],
    "land_on_tag_id": 0,
    "follow_tag_id": 0,
    "en_apriltag_fixed_frame": false,
    "fixed_apriltags": [{
    "tag_id": 0,
    "R_tag_to_fixed": [[0, -1, 0], [1, 0, 0], [0, 0, 1]],
    "T_tag_wrt_fixed": [0, 0, 0]
    }],
    "en_transform_mavlink_pos_setpoints_from_fixed_frame": true,
    "en_fixed_frame_pipe": false,
    "fixed_frame_filter_len": 5
    }
    ~ #

    I edited the QGC IP to my laptop's IP and QGC still doesnt see it. I will try from a different computer.



  • No luck on different computer. I just tried the ESC cal as well and no luck.


  • Dev Team

    What kind of computer are you using, Linux, Windows?

    If Windows, you likely need to configure the firewall (maybe easier to just disable the windows firewall for this test).

    You can use the USB connection straight to the blue connector to get a connection to QGC.

    But, if you have QGC running, the ESC calibration tool won't work because QGC will have taken ownership of the port.



  • I've been testing on a Macbook Pro. I can get QGC via the USB port, just not via Wifi. And the motors dont spin above minimum armed PWM.


  • Dev Team

    I just went through similar yesterday on a new board we're developing. PX4 is configured to expect a magnetometer, you'll want to set the sys_has_mag param to 0, and GPS_1_CONFIG to off/none via the QGC.

    I can get on a screen share after a bit if needed so just let me know if you want to wait till then.



  • I just did another test randomly while eating my lunch and it worked as expected. So I did a maiden and checked stabilize, althold, and position mode and all modes flew well. We have lots of snow here so cant test too much more outdoors.


  • Dev Team

    OK great!! Please holler if you hit any other snags.



  • Another snag... Seems like the voxl-vision-px4 is spotty at starting. I am trying to fly again and no luck. I ran the status command and the same failure as before.


  • Dev Team

    Hi @Riley-Dove ,

    Want to try to do a screen share tomorrow AM? I'll send an email to what's registered on this account.

    Some of the errors looked like config file parsing, but the first one was truncated a bit.

    If the device is in the failed currently, and you don't mind, you can throw the output of systemctl status voxl-vision-px4 -l here in preps.

    Thanks, we'll figure out what's going on!


Log in to reply