VOXL not connecting to QGC





  • @stevet Thank you so much for incredible insights into voxl-vision-px4 package as well as pointing to specific code which may be related to this issue.

    I changed offboard mode to "trajectory" in voxl-vision-px4.conf and tried running mavros with it still no luck. Still I face same issue of mavros requesting home position from PX4.

    I dont know exactly when PX4 sends home position to mavros, as in when copter lifts off or even on ground. But still it would be worth a try to run mavros once copter is off the ground holding its position.

    @James-Strawson Any inputs over here? Does PX4 publishes home position to mavros when qvio server is initialised and sending VIO to FCU. I guess it should since people generally must be using figure eight offboard example with mavros from ground which needs mavros to be taking in all setpoint_raw mavros topics inputs?


  • Dev Team

    @stevet said in VOXL not connecting to QGC:

    voxl-mavlink

    When using MAVROS the vvpx4 offboard_mode setting should be set to "off" since the figure 8 and trajectory modes let vvpx4 send offboard commands which would naturally conflict with offboard commands coming from MAVROS.

    the "HP: requesting home position" message is perfectly normal, I've always seen it come up and it's never stopped me from running the mavros figure-8 example.



  • @James-Strawson Can you please elaborate on setting vvpx4 offboard_mode "off" while using MAVROS. I am having a similar issue: my drone does not take off, and the screen displays "requesting home position" when I am running mavros_test.sh file.
    If you can guide me through the steps of turning vvpx4 offboard_mode "off", that would be great. Thank You.



  • @James-Strawson I also set offboard_mode of vvpx4 to "off" while running mavros test and the drone still does not take off. I have also attached the pictures of what I changed.
    IMG_2813 2-min.JPG
    IMG_2814-min.JPG



  • @James-Strawson Thank you for your response.

    Even if I ignore "HP: requesting home position" I am not getting any data over /mavros/global_position/local topic which I think needs home position to be set correctly. Intention behind using /mavros/global_position/local is to have odometry in FLU frame which directly fits into most of the path planners for further work. Any inputs over here?

    I did few more experiments but with no luck :

    • I have seen in some forums like this fake gps plugin in px4 can be used to set home position. This plugin is present in px4 plugin list but isnt active maybe.

    • I tried running rosservice call /mavros/cmd/set_home which always returns false in result which means it is failing. My qvio data is been forwarded to px4 and I can see it on QGC terminal as well.

    Any thoughts on getting /mavros/global_position/local or /mavros/local_position/odom topics working?



  • @parbat101 Probably you can try enabling "en_send_vio_to_qgc": true in your above shown config file? In my case I can arm drone in manual/position mode easily, just using mavros is the concern.



  • @Aks Thank you for your reply. My problem is also with MAVROS; it does not take off at last step and requests for home position. The drone (VOXL m500) takes off and I can control it flawlessly on manual and position flight mode.

    I also enabled "en_send_vio_to_qgc" after your suggestion; the MAVROS flight did not work. It still does not take off in the MAVROS flight test. For manual mode and position flight mode, I did not have any problems.
    I am not sure what is the problem with the MAVROS flight???

    Edited.jpg
    IMG_0116.jpg



  • hey!@parbat101
    Didi you figure out the way to set local position as home? If so please post it here, that would be helpful
    thank you



  • @Steve-Turner Hey please I need you help setting up ADB for my newly purchased VOXL CAM. I already started a discussion "Broken parts".


Log in to reply