No connection to QGroundControl after upgrading to dev channel



  • Worked before the upgrade from stable to dev but.
    The voxl-vision-px4 service emits:

    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_insert_pc, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_insert_pc, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_insert_pc, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_insert_pc, ringbuf uninitialized
    Jan 01 00:04:08 apq8096 voxl-vision-px4[1954]: ERROR in obs_pc_ringbuf_cleanup_old, ringbuf uninitialized
    

  • Dev Team

    Hello, do you mind sharing the contents of the config file /etc/modalai/voxl-vision-px4.conf and the output from voxl-vision-px4 when started from a terminal? I'd like to see what it prints before getting to the ringbuf error. Thank you!

    James



  • Hi,

    I was able to fix the ringbuffer error by running the voxl-configure-vision-px4 after the update.
    However there still is no connection to QGroundControl. Running tcpdump udp port 14550 -vv hints that the voxl-vision-px4 server is not sending packets (consistent with the lack of output with --debug_udp_send) .

    /**
     * VOXL Vision PX4 Configuration File
     *
     */
    {
            "qgc_ip":       "192.168.8.89",
            "en_localhost_mavlink_udp":     true,
            "en_secondary_qgc":     false,
            "secondary_qgc_ip":     "192.168.2.1",
            "qgc_udp_port_number":  14550,
            "localhost_udp_port_number":    14551,
            "udp_mtu":      512,
            "en_vio":       true,
            "en_voa":       true,
            "en_send_vio_to_qgc":   false,
            "en_send_voa_to_qgc":   false,
            "en_set_clock_from_gps":        true,
            "en_force_onboard_mav1_mode":   true,
            "en_reset_px4_on_error":        true,
            "qvio_auto_reset_quality":      0.00050000002374872565,
            "horizon_cal_tolerance":        0.300000011920929,
            "voa_upper_bound_m":    -0.15000000596046448,
            "voa_lower_bound_m":    0.15000000596046448,
            "offboard_mode":        "off",
            "follow_tag_id":        0,
            "figure_eight_move_home":       true,
            "en_tag_fixed_frame":   false,
            "fixed_frame_filter_len":       5,
            "en_transform_mavlink_pos_setpoints_from_fixed_frame":  false
    }
    
    
    loading our own config file
    =================================================================
    Parameters as loaded from config file:
    qgc_ip:                     192.168.8.89
    en_localhost_mavlink_udp    1
    en_secondary_qgc:           0
    secondary_qgc_ip:           192.168.2.1
    qgc_udp_port_number:        14550
    localhost_udp_port_number:  14551
    udp_mtu:                    512
    en_vio:                     1
    en_voa:                     1
    en_send_vio_to_qgc:         0
    en_send_voa_to_qgc:         0
    en_set_clock_from_gps:      1
    en_force_onboard_mav1_mode: 1
    en_reset_px4_on_error:      1
    qvio_auto_reset_quality:    0.000500
    horizon_cal_tolerance:      0.300000
    voa_upper_bound_m:          -0.150000
    voa_lower_bound_m:          0.150000
    offboard_mode:              off
    follow_tag_id:              0
    figure_eight_move_home:     1
    en_tag_fixed_frame:         0
    fixed_frame_filter_len:     5
    en_transform_mavlink_pos_setpoints_from_fixed_frame:0
    =================================================================
    loading extrinsics config file
    starting geometry module
    starting px4 monitor
    starting px4 mavlink
    starting udp mavlink
    Adding manual QGC IP address to udp connection list: 192.168.8.89
    Added new UDP connection to 192.168.8.89
    starting px4 shell
    starting fixed pose input
    starting vio manager
    starting tag manager
    starting voa manager
    starting control input pipe
    Init complete, entering main loop
    Connected to TOF
    Connected to voxl-qvio-server
    updating to use imu: imu1
    done updating transforms to use imu: imu1
    

    Enabling en_send_vio_to_qgc or en_send_voa_to_qgc will send udp packets which show up in QGroundControl MAVLink Inspector (but still no proper connection)



  • @jlinnpmd can you drop which services are running with ‘voxl-inspect-services —version’?

    I had a similar issue upgrading to dev channel recently as well and something between the ‘voxl-mavlink-server’ and ‘voxl-vision-PX4’ wasn’t right until I reinstalled/installed the mavlink server.

    I also added an additional opkg dev channel for VOXL1 may be http://voxl-packages.modalai.com/dists/apq8096/dev/binary-arm64/ based on where builds out of gitlab CI are getting dropped. Seemed like quite a few dependencies are missing from the dev channel listed in docs at this time and this had newer dependencies as required by the latest voxl-suite.

    Take my advice with a grain of salt… the Modal team probably has a better answer but both above fixed my QGC connectivity issues without having to build things myself.



  • Oh wow, I totally overlooked the fact that the mavlink server seems to have been disabled during upgrade. Anyway thanks for the more up to date repo link, that might be very useful


Log in to reply