rodep ssl error



  • Hello,
    I am not able to init rosdep. When I do sudo rosdep init it keeps giving error

    ERROR: cannot download default sources list from:
    https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/sources.list.d/20-default.list
    Website may be down.
    

    I tried manually downloading 20-default.lit using wget and placing it inside /etc/ros/rosdep/sources.list.d/ directory and tried running rosdep update still it says connection timeout whereas these url are perfectly working when open through browser

    yocto:/etc/ros/rosdep/sources.list.d# rosdep update
    reading in sources list data from /etc/ros/rosdep/sources.list.d
    Warning: running 'rosdep update' as root is not recommended.
      You should run 'sudo rosdep fix-permissions' and invoke 'rosdep update' again without sudo.
    ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml]:
    	<urlopen error [Errno 110] Connection timed out> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml)
    ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml]:
    	<urlopen error [Errno 110] Connection timed out> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml)
    ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml]:
    	<urlopen error [Errno 110] Connection timed out> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml)
    ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml]:
    	<urlopen error [Errno 110] Connection timed out> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml)
    ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml]:
    	Failed to download target platform data for gbpdistro:
    	<urlopen error [Errno 110] Connection timed out>
    Query rosdistro index https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml
    ERROR: error loading sources list:
    	<urlopen error <urlopen error [Errno 110] Connection timed out> (https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml)>
    yocto:/etc/ros/rosdep/sources.list.d#
    

    I tried doing this updating certificates but it didn't work

    update-ca-certificates
    cp /etc/ssl/certs/ca-certificates.crt /usr/lib/ssl/certs
    

    I am using voxl-flightdeck and these are the versions of onboard images

    --------------------------------------------------------------------------------
    system-image:    ModalAI 2.5.2 BUILDER: ekatzfey BUILD_TIME: 2020-08-24_00:08
    kernel:          #1 SMP PREEMPT Wed Sep 9 22:28:09 UTC 2020 3.18.71-perf
    factory-bundle:  1.0.1
    --------------------------------------------------------------------------------
    architecture:    aarch64
    processor:       apq8096
    os:              GNU/Linux
    --------------------------------------------------------------------------------
    voxl-suite:
    Package: voxl-suite
    Version: 0.2.0
    Depends: docker, imu_app (= 0.0.6), libvoxl_io (= 0.5.2), voxl-cam-manager (= 0.2.2), voxl-docker-support (= 1.1.1), voxl-hal3-tof-cam-ros (= 0.0.2), voxl-modem (= 0.10.0), voxl-nodes (= 0.0.8), voxl-rtsp (= 1.0.2), voxl-utils (= 0.5.2), voxl-vision-px4 (= 0.6.8), voxl_imu (= 0.0.4), voxl-time-sync (= 0.0.1), voxl-vpn (= 0.0.2), librc_math (= 1.1.2), libmodal_pipe (= 1.2.2), modalai-vl (= 0.1.3)
    Status: install user installed
    Section: base
    Architecture: armv7a
    Maintainer: james@modalai.com
    MD5Sum: af706cd3c1ea59f274f2ed9b93141f1d
    Size: 870
    Filename: voxl-suite_0.2.0.ipk
    Description: meta-package to install all of the voxl-suite
    Installed-Time: 4024
    
    --------------------------------------------------------------------------------
    


  • I am able to get rosdep working by updating ca-certificates through this

    update-ca-certificates
    cp /etc/ssl/certs/ca-certificates.crt /usr/lib/ssl/certs
    

    and setting SSL_CERT_FILE variable to point to ca-certificate path

    export SSL_CERT_FILE=/usr/lib/ssl/certs/ca-certificates.crt
    

    but now rosdep dos not detect OS used by Voxl

    ERROR: Rosdep experienced an error: Could not detect OS, tried ['windows', 'ubuntu', 'slackware', 'rhel', 'qnx', 'osx', 'opensuse', 'opensuse', 'mint', 'linaro', 'gentoo', 'funtoo', 'freebsd', 'fedora', 'elementary', 'debian', 'cygwin', 'centos', 'arch']
    
    


  • Thanks for posting the ssl fix. We're looking into this. We don't typically use rosdep for anything. Is there something specific you need to get working?

    A more traditional ROS experience is easy to achieve running Ubuntu in a Docker on VOXL : https://docs.modalai.com/docker-on-voxl/



  • I was trying to rosdep update on some custom packages. But then ended up adding source directly to the workspace.


Log in to reply