RM3100 Magnetometer

  • Hi ModalAI, ^^

    I'm encountering issues with a certain compass on your flight controller.
    I detailed the issue here link text
    but in general I wonder, do you guys have any specific experience with this mag unit?

    I'll try and keep you updated. Thanks for your work, guys!

  • Dev Team

    Hi @m4v3r ,

    I'm nearly positive I tested CONNECTIVITY on the "drotek" version of this with success (I mainly remember that I did fry one out of two by reversing GND and VDD...).

    I'll try to find this when back in the office and give it a go and report back.

  • @modaltb Hello there, I just wanted to give a little update here:
    I managed to connect it in a way that it's now appearing on the I2C bus as 23 by putting a 10k resistor on vcc and the I2C-enable pin but it's still not being detected by PX4 as a magnetometer and I couldn't start it manually either.
    I do see it on the bus just like with another mag ("gy-85" board using the QMC5883L and two other IMUs which also appear on the bus when scanned) but can't get it to start and work in PX4.

  • Hey, just giving some more information and a little bump since I'm still in desperate need of this compass working on my drone.
    Please try and have another look into this for me if you could... 😉
    thanks so much and a perfect weekend for everyone.

    unit on bus:

    Tried starting it manually to no avail:

  • Dev Team

    @m4v3r , sorry for the lag. This mag is not in our office. What I would do myself is go into the driver and see what's happening. We don't re-sell this mag and I don't have one so I'm stuck a bit. Do you want to ship one to us and we put a debugger on PX4 and see what's up?

  • @modaltb Hey hey know it's been forever but just right now I finally got it working. 🙂
    I adjusted the adress in the corresponding driver's .h file and now it's finally running.
    thanks again for going through this with me.

Log in to reply