WLAN not enabled/showing up.



  • Wlan will not show up under ifconfig. Meaning that neither station or softap modes will work with voxl-wifi. I have tried restarting the wlan services with systemctl. I am wondering if this is a firmware issue. When I try restarting with:

    systemctl restart wlan_daemon.service
    

    I get this error:

    Failed to restart wlan_daemon.service: Unit wcnss_wlan.service failed to load: No such file or directory.
    

    I have also tried:

    systemtctl restart start_wlan_services.service
    

    This seems like maybe a break in the firmware and drivers somewhere? This has happened to two boards that have not been in flight and that had wlan/wifi working before.

    I would appreciate any help to resolve this issue. I do not believe it is a hardware issue as both boards have the wifi antennas connected securely.



  • Actually,

    Turns out that although the antennas were working properly before and seemed to have a good connection, replacing the antennas solved this issue.



  • Thank you very much for following up! Was going to recommend just reinstalling the system image as described here, but replacing the antennas is even easier

    Here is the antenna we use for reference https://www.digikey.com/en/products/detail/molex/1461531100/8543422


Log in to reply