Motors not responding to Throttle



  • Hi,

    I'm working with the VOXL Flight Deck and Hobbywing Xrotor 60A ESC. When armed, the motors start spinning but when I increase the throttle, they don't seem to react and keep spinning at the arming speed. The motors do spin at various speeds when controlled via QGroundControl. I've checked the RC throttle mapping. The PX4 does receive RC commands from the transmitter. The sensors are calibrated and working. The ESC is also calibrated. However, the PID controller does not plot the setpoint and response (Both rate and attitude).
    rt.PNG
    I'm not sure why this issue occurs. Any tips on this issue would be greatly appreciated. Thank you.

    Regards,
    Adarsh


  • Dev Team

    Hi @Adarsh96 ,

    I've seen this before if the estimator isn't running, which is normally caused by either a missing magnetometer when you have the vehicle setup to use a mag, or trying to not use a mag and to get your yaw from VIO. You can check this from a MAVLink console, ekf2 status should print out the status. If that's not running, you won't get any attitude readings (and won't be able to arm either).

    Can you confirm that you are using the PX4 FW that was shipped with the Flight Deck? Or did you update it via QGC?

    Can you clarify if you have a magnetometer setup or not?



  • Hi,
    Thank you for your reply. The board does run the v1.11.3-0.0.5 firmware release. I updated the firmware using QGC. As for the ekf2 status, this is what I get:
    89.PNG

    Also, I set the SYS_HAS_MAG parameter to 0, disabling the magnetometer.
    90.PNG
    The reason, I disabled the parameter was I was not able to calibrate the magnetometer. After placing it in all the required orientations, the calibration data does not get saved.

    As for arming the motor, the motor does arm and spin. But I'm not able to control the throttle. Could you help me solve this issue? Thanks.

    Best,
    Adarsh


  • Dev Team

    Mainline PX4 will not allow you to arm without magnetometer, so you are likely seeing that EKF is not valid because it's not valid! ;). The system by default expects a mag and even if you disable the check, EKF will fail to initialize (this is EKF/PX4 behaviour, not ModalAI).

    If you want to fly without a mag, you need to use the ModalAI branch (file here

    And then you need to enable the aid mask to allow the system to use external vision for yaw: https://gitlab.com/voxl-public/flight-core-px4/px4-parameters/-/blob/master/helpers/ekf2_indoor_vio.params#L7



  • @Adarsh96 Hey there, reading your issue reminded me of something I once experienced.
    EKF not initializing position is a separate issue but I can tell you if you're able to arm the quad amd have the motors spinning, it should be good.
    What flightmode did you arm it in?
    Because with some you need to raise throttle above 60% to takeoff.
    Just a thought but you might have just been in the wrong mode bc quad arming means you're basically ready to fly. 😉


Log in to reply