Voxl PX4 firmware not working



  • I have a VOXL Flight deck mounted on a quadcoptor frame using simonK esc.
    Currently the motors were not spinning when test were done through Qgroundcontrol.
    I reflashed the voxl and updated firmware of px4 using the firmware given in this website.

    But it still did not work. Then I tried the flashing coptor firmware
    This works as ECS initialise as they give a second jingle. But now voxl does not recognise or communicate to the PX4 thus voxl-vission-px4 doesent really work and Qgroundcontrol is not being able to connect to px4 using wifi.

    Thus , I think there is a firmware issue so what is the solution for this , how can I solve this?

    Thank you in advance


  • Dev Team

    ArduPilot and PX4 are both flight control software and mutually exclusive.

    Can you try going back to PX4 and seeing if the VOXL can communicate with the flight controller? https://docs.modalai.com/update-flight-core-firmware/



  • I tried the link you provided,the ECS is not intalising and ardupilots firmware and voxl is not able to communicate with the px4.
    Also stats provided in voxl portal about px4 there is not available.

    Is it possible we meet on a call on any meeting platform, So that we can solve this issue easily?
    Thank you


Log in to reply